+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Application errors

Application errors

29 posts, 0 answered
  1. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    04 Jan 2008
    Link to this post
    Hi,

    Every couple of days I get a string of about 5 or 6 errors from one of my Sitefinity sites from various pages but they all seem to have a very similar error message. I haven't the faintest idea what may be going wrong but I was wondering if you could confirm whether it is a Sitefinity error or not and if you could point me in the right direction.

    The site in question gets about 100 hundred visitors a day and is running the latest version and service pack.

    Thanks

    Seth


    - health monitoring
    ** Application Information **
    ---------------



    ** Events **
    ---------------
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 1/4/2008 4:08:51 AM
    Event time (UTC): 1/3/2008 5:08:51 PM
    Event ID: 3039ceecb942436ba53340c457c007d0
    Event sequence: 338
    Event occurrence: 6
    Event detail code: 0

    Process information:
       Process ID: 4228
       Process name: w3wp.exe
       Account name: NT AUTHORITY\NETWORK SERVICE

    Exception information:
       Exception type: System.InvalidOperationException
       Exception message: RegisterRequiresControlState can only be called before and during PreRender.

    Request information:
       Request URL:
       Request path: /register.aspx
       User host address: 165.166.128.204
       User:
       Is authenticated: False
       Authentication Type:
       Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:
       Thread ID: 11
       Thread account name: NT AUTHORITY\NETWORK SERVICE
       Is impersonating: False
       Stack trace:    at System.Web.UI.Page.RegisterRequiresControlState(Control control)
      at System.Web.UI.Control.AddedControl(Control control, Int32 index)
      at System.Web.UI.ControlCollection.Add(Control child)
      at Telerik.Cms.Web.InternalPage.CreateChildControls()
      at System.Web.UI.Control.EnsureChildControls()
      at System.Web.UI.Control.FindControl(String id, Int32 pathOffset)
      at System.Web.UI.Page.FindControl(String id)
      at System.Web.UI.Page.ProcessPostData(NameValueCollection postData, Boolean fBeforeLoad)
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

  2. Bob
    Bob avatar
    330 posts
    Registered:
    24 Sep 2012
    04 Jan 2008
    Link to this post
    Hello Seth,

    Could you send us the sitefinity.log file located in the ~/App_Data folder? It should contain similar exceptions logged but with some extra information that would be valuable in order to investigate the problem.

    Thank you for your cooperation in advance.

    Regards,
    Bob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    04 Jan 2008
    Link to this post
    Hi,

    I didn't realise the log had more info.

    You can grab it from here

    Thanks,

    Seth
  4. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    10 Jan 2008
    Link to this post
    Hello Seth Cleaver,

    We had a look at the log file but we cannot determine the reason for this error, especially when it appears occasionally. Please send us the project that demonstrates this behavior so we can go on looking into this.
    Open a support thread and attach the project and database as a zip archive.
    Sorry for not being able to help you right away.


    Sincerely yours,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Allison
    Allison avatar
    2 posts
    Registered:
    14 Jan 2008
    28 Jan 2008
    Link to this post
    I am seeing the same errors in my log file.  Have you been able to figure anything out with this yet?
  6. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    29 Jan 2008
    Link to this post
    Hello Allison,

    Unfortunately, the problem has not been localized yet. It will be very helpful if you could give us more information to reproduce this behavior and figure out what causes the exception.

    Thanks for your cooperation in advance.
     
    Best wishes,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    06 Feb 2008
    Link to this post
    Hi,

    I have some more information of this issue which Sean Molam discovered after I was discussing the issue with him.

    It appears like the error happens when a users browser UserAgent is empty, hopefully you follow what we mean by this.

    On testing with Fiddler the Sitefinity demo site and the site I am having issues, sean got the error to appear.

    Sean did a trace on the IP from one of the many instances of the errors in the log and it came from the Hong Kong Cable TV company, so my guess is it was someone browsing using their TV or something that used a browser that doesn't set a UserAgent. That is my guess.

    I am currently getting about 15 errors a day of this description.

    Thanks,

    Seth
  8. Nikifor
    Nikifor avatar
    232 posts
    Registered:
    18 May 2013
    06 Feb 2008
    Link to this post
    Hi Seth Cleaver,

    Thank you very much for the elaboration.

    The fact that we are now focusing on the 3.2 beta release will cause a small delay of our response. The issue looks quite complicated and we'll definitely need more time for reproducing and testing.
    As soon as we finalize the beta release, we'll consider your request.

    Thanks for your patience and understanding.

    Sincerely yours,
    Nikifor Hristov
    the Telerik team


    Instantly find answers to your questions at the new Telerik Support Center
  9. pbwebmaster
    pbwebmaster avatar
    17 posts
    Registered:
    15 Apr 2007
    11 Feb 2008
    Link to this post
    Any progress on this bug?  We just launched our website on sitefinity today, and are see it a lot in our error logs.  Our site gets around 2,000 unique visitors/day, and we're seeing this error a lot so far.

    Any help or suggestions would be appreciated.
  10. Nikifor
    Nikifor avatar
    232 posts
    Registered:
    18 May 2013
    12 Feb 2008
    Link to this post
    Hello brettlj,

    We already addressed the issue and its fix is included in the next release. Here are the dates targeted for its availability:

    • Beta release - 20 February, 2008
    • Final release  - 5 March, 2008
    • Service Pack 1 - 20 March, 2008

    Thank you very much for your time.

    Best wishes,
    Nikifor Hristov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  11. pbwebmaster
    pbwebmaster avatar
    17 posts
    Registered:
    15 Apr 2007
    12 Feb 2008
    Link to this post
    Thanks Nikifor.  Is this part of the 3.2 release or a separate fix for 3.1?
  12. Sonya
    Sonya avatar
    231 posts
    Registered:
    24 Sep 2012
    12 Feb 2008
    Link to this post
    Hello brettlj,

    The fix will be part of the new 3.2 version of Sitefinity.


    All the best,
    Sonya
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  13. viscious
    viscious avatar
    31 posts
    Registered:
    10 Aug 2006
    12 Mar 2008
    Link to this post
    did this make it into the 3.2 official release?
  14. viscious
    viscious avatar
    31 posts
    Registered:
    10 Aug 2006
    26 Mar 2008
    Link to this post
    No it did not.

    Dissapointing.
  15. Nikifor
    Nikifor avatar
    232 posts
    Registered:
    18 May 2013
    01 Apr 2008
    Link to this post
    Hello viscious,

    Please accept our sincere apologies for the delay of our response. We have tested and are still unable to reproduce the error.

    Erick, could you please confirm that the error still appears after upgrading your project to Sitefinity version 3.2.

    Could anyone send us a project which reproduces this error so that we could investigate it?

    Thank you for your cooperation.

    Greetings,
    Nikifor
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  16. Zack
    Zack avatar
    41 posts
    Registered:
    18 Apr 2007
    01 Apr 2008
    Link to this post
    Due to extensive DB dependencies, etc. I do not have a project that I can send you but I can give you a few additional details about the scenario in which we are encountering a similar error.

    - Sitefinity 3.2 (converted to a Web Application Project)

    - We have sf404.aspx configured as our 404 page in IIS in order to support "Entensionless Urls", e.g. www.mysite.com/faq

    - This error seems to show up rather randomly for us ... in fact, we never see an instance of this error where the User Agent is empty ... it happens on "live" production pages in our site as well as when we're accessing admin pages in the Sitefinity directory

    Hoping this information helps get us closer to a resolution...

    Zack
  17. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    15 Apr 2008
    Link to this post
    I just had this error occur on a brand new installation of 3.2 service pack 1.
  18. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    27 Apr 2008
    Link to this post
    I'm using v3.2 (no SP1) and I am also getting same error when I double click the Search button in SF Search control.
    ------------------------------------------------------------------------------

    Exception Type: System.InvalidOperationException

    Message: RegisterRequiresControlState can only be called before and during PreRender.

    Source: System.Web

    Stack Trace:
       at System.Web.UI.Page.RegisterRequiresControlState(Control control)
       at System.Web.UI.Control.AddedControl(Control control, Int32 index)
       at System.Web.UI.ControlCollection.Add(Control child)
       at Telerik.Cms.Web.InternalPage.CreateChildControls()
       at System.Web.UI.Control.EnsureChildControls()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    Any solution to this problem ?
  19. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Apr 2008
    Link to this post
    Hello Zubair,

    Good news everyone - we managed to fix this issue.
    We have reproduced it with load tests and custom controls. It does not appear any more, but our tests for this will continue.

    The fix will be available in Service Pack 2, scheduled for May.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  20. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    29 Apr 2008
    Link to this post
    Hi,

    I am glad you have finally found the error. Having reported this almost 2 months ago I have been waiting eagerly to see it fixed as I get so many error reports a day from this one bug.

    Thanks

    Seth
  21. UI Crew
    UI Crew avatar
    151 posts
    Registered:
    27 Sep 2012
    05 May 2008
    Link to this post
    Hi,

    To all who need to fix this bug there is a solution posted on the Sitefinity Blog... http://blogs.sitefinity.com/Ivan/Post/08-05-02/registerrequirescontrolstate_error_workaround.aspx  Since applying this fix I haven't had a single error! Thanks Ivan!

    Regards,

    Seth 
  22. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    05 May 2008
    Link to this post
    Wow, I had not checked their blog otherwise, thanks for posting the news here Seth.
  23. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    01 Nov 2008
    Link to this post
    We're using 3.2 SP1 and applied this fix.  We no longer get this on the public site, but get the error on the Admin (sitefinity/admin/) side.  Anyone else have this problem?

    J
  24. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    01 Nov 2008
    Link to this post
    Hello Jason M,

    Could you please send us the stack trace of the error?

    Best wishes,
    Georgi
  25. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    01 Nov 2008
    Link to this post
    Wow, that was quick Georgi!

    Here it is (I replace our web sites URL in the link to "oursite"):

    11/1/2008 4:20:51 PM [UNKNOWN]
    ************************************************************************************
    ID: 75dab66a-2817-4f53-aa76-45d80adce551; Code: 3005; Occurrence: 45; Sequence: 10204
    ------------------------------------------------------------------------------------

    Application information:
     Machine name: OTTWEB1
     OS Version: Microsoft Windows NT 5.2.3790 Service Pack 2
     Product Version: 3.2.1526.2
     Application Path: D:\share\webroot\cms\
     Debug: True

    Process information:
     Process ID: 3192
     Process Name: w3wp

    Request information:
     Request URL: /conf/Fall2008TechnicalForecastingSeminar/Fall2008technicalforecastingseminar.aspx?cmspagemode=preview&locknavigation=true
     Rewrite URL: http://www.site.com/conf/fall2008technicalforecastingseminar/fall2008technicalforecastingseminar.aspx?cmspagemode=preview&locknavigation=true
     Url Referrer: http://www.site.com/sitefinity/admin/pages.aspx?select=5e07f808-1a1a-4f07-849e-f6f890293c86&action=saved
     Is Authenticated: True
     Authentication Type: Forms
     User: lugtigheid@oursite.com
     User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; MS-RTC LM 8)
     User Address: 199.71.104.1

    Variables:
     AspSessionIDManagerInitializeRequestCalled: True
     cmspagemode: preview
     cmscurrcult: en
     cmspageid: 5e07f808-1a1a-4f07-849e-f6f890293c86
     Sitefinity.OriginalURL: /conf/fall2008technicalforecastingseminar/fall2008technicalforecastingseminar.aspx
     RadControlRandomNumber: 0
     cmsurlcontext: Telerik.Cms.Web.CmsUrlContext

    - L0 -------------------------------------------------------------------------------

    Exception Type: System.InvalidOperationException

    Message: RegisterRequiresControlState can only be called before and during PreRender.

    Source: System.Web

    Stack Trace:
       at System.Web.UI.Page.RegisterRequiresControlState(Control control)
       at System.Web.UI.Control.AddedControl(Control control, Int32 index)
       at System.Web.UI.ControlCollection.Add(Control child)
       at Telerik.Cms.Web.PreviewPage.CreateChildControls()
       at System.Web.UI.Control.EnsureChildControls()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    ------------------------------------------------------------------------------------


  26. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    03 Nov 2008
    Link to this post
    Hello Jason M,

    Oh, yes it is the same error. I just wanted to be sure, in order to provide you with the right solution as soon as possible.

    After my previous post, I realized that the solution that is already provided, is indeed intended for the public part of the web site - cmsentrypoint.aspx and the InternalPage class are not used in the Admin section at all. Enough words, here goes the solution - I have attached two more classes that you should place in your App_Code directory:
    • CustomAdminEditPageHandler .cs - fixing the problem in Edit Page mode
    • CustomAdminPreviewPageHandler.cs - fixing the problem in Page Preview mode
    They contain the same code as the used in the public part.

    Please open the file EditPage.aspx located in [YourProject]\Sitefinity\Admin and change it to contain:
    <%@ Page Inherits="CustomAdminEditPageHandler" MasterPageFile="~/Sitefinity/Dummy.master" %> 

    One more file should be changed - PreviewPage.aspx located in the same directory:
    <%@ Page Inherits="CustomAdminPreviewPageHandler" MasterPageFile="~/Sitefinity/Dummy.master" %> 

    These two pages are not inheriting the new classes which you placed in the App_Code directory. This should fix the things in the Administrative area.

    Thanks for your cooperation.

    Greetings,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  27. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    03 Nov 2008
    Link to this post
    Thanks Georgi, this fixed my problem!
  28. Bill
    Bill avatar
    53 posts
    Registered:
    28 Jun 2006
    02 Jan 2009
    Link to this post
    What is the deal with these code snippet text boxes on this forum being one line, that has to be taken care of sooner or later.
  29. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 Jan 2009
    Link to this post
    Hello William,

    In the particular case, the code was exactly 1 line :)

    Could you please elaborate on the idea? I agree that the code might be presented differently that is why I am asking about your vision here.

    All the best,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
29 posts, 0 answered