Try Now
More in this section

Forums / Bugs & Issues / Blank Title for Polls and Lists modules

Blank Title for Polls and Lists modules

2 posts, 0 answered
  1. Nitin
    Nitin avatar
    51 posts
    14 Aug 2007
    22 Oct 2007
    Link to this post

    When I click on Polls or Lists module menu options, the Title in Control Panel comes out blank. But if you click on All Posts or All Lists in the command panel, the title is rendered properly....

    Also, it appears that setting the ControlPanelBase.tlt is not a reliable way to display the title of a custom module. For example in my class (derived from ControlPanelBase, I have the following code in CreateChildControls():

                base.tlt = "All Indexes";  

    But, the title is not displayed as "All Indexes" when the menu option for my custom control is clicked. Navigating using command panel renders it correctly - Just like the Lists and Polls issue mentioned above...

    I am running v3.0 SP2.

  2. Pepi
    Pepi avatar
    981 posts
    20 Oct 2016
    22 Oct 2007
    Link to this post
    Hi Nitin,

    Thanks a lot for pointing out this issue. You are right that the title of Lists and Polls should be displayed right away after going to the corresponding module. This will be fixed for the upcoming SP1. As a note of gratitude your Telerik points have been updated.

    As for the initial title of your module, you should override Title property of the base class as follows:

    /// <summary> 
    /// Gets the title of ControlPanel. 
    /// </summary> 
    public override string Title 
                    if (String.IsNullOrEmpty(this.tlt)) 
                        this.tlt = "Module Title"
                    return this.tlt; 

    Hope this helps.

    Kind regards,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered