+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Blogs ArchiveTemplate produces invalid markup

Blogs ArchiveTemplate produces invalid markup

3 posts, 0 answered
  1. Milkman Dan
    Milkman Dan avatar
    14 posts
    Registered:
    11 Mar 2008
    27 May 2008
    Link to this post
    This control seems to want to wrap itself in a SPAN element but that won't validate because there are block level elements (like UL and LI ) housed within it. I can't seem to find any way to get rid of the anonymous SPAN.
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    28 May 2008
    Link to this post
    Hello Milkman Dan,

    I would recommend you create your own control that inherits Sitefinity BlogArchive class and override RenderBeginTag and RenderEndTag methods. Please note that you should register your custom control in the web.config file to display it in "Add Controls" toolbox:

    <toolboxControls> 
    ... 
        <add name="BlogsArchiveExt" section="Blogs" type="MyNamespace.BlogsArchiveExt, app_code" /> 
    ... 

    For your convenience I have attached a simple example.

    Sincerely yours,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Milkman Dan
    Milkman Dan avatar
    14 posts
    Registered:
    11 Mar 2008
    28 May 2008
    Link to this post
    Thanks, I'll give this a try after the service pack update. One less line in the web.config to worry about :D
Register for webinar
3 posts, 0 answered