+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Bug with section system.web.extensions

Bug with section system.web.extensions

2 posts, 0 answered
  1. Paul
    Paul avatar
    176 posts
    Registered:
    18 Nov 2008
    08 Oct 2010
    Link to this post

    Greetings!

    Today I was trying to deploy my new site version and found that web.config for Blank project has a missing section.  I create a new version from blank project Sitefinity 3.7 SP4 .NET 4.0 and my old version on Sitefinity 3.6 SP2 .NET 3.5. When I start deploying process I get 500.19 error: "The requested page cannot be accessed because the related configuration data for the page is invalid." ("The configuration section 'system.web.extensions' cannot be read because it is missing a section").

    After some googling I found that web.config should have such section:

    01.<configSections>
    02.<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    03.  <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    04.    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    05.    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    06.      <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
    07.      <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    08.      <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    09.      <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
    10.    </sectionGroup>
    11.  </sectionGroup>
    12.</sectionGroup>
    Maybe this will help somebody in future.

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Oct 2010
    Link to this post
    Hello Paul,

    Thank you for using our services.

    The problem is coming from the fact that you are trying to run a .NET 4.0 website in an application pool which is set to run an older version of .NET. In .NET 4.0 the system.web.extensions configuration section should not be declared as the machine.config file has been already set to include this section declaration. Try setting your application pool to run in .NET 4.0. This KB article will help you achieve this. Also you can check this MSDN article for changes in the .NET 4.0 configuration files.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered