+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Caching makes all pages the same

Caching makes all pages the same

6 posts, 0 answered
  1. Slawek
    Slawek avatar
    16 posts
    Registered:
    16 Feb 2009
    13 Jan 2011
    Link to this post
    When I enable Caching on homepage all other pages display homepage content. What could be the reason for this behavior?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Jan 2011
    Link to this post
    Hello Slawek,

    • Could you describe some more about this issue?
    • What is the structure of your pages - are all pages located under your home page?
    • How do you show your content - which controls you use?
    • Can you replicate the issue on http://demo.sitefinity.com/Home.aspx
    • Which version of Sitefinity you use?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Slawek
    Slawek avatar
    16 posts
    Registered:
    16 Feb 2009
    13 Jan 2011
    Link to this post
    Hi Ivan,

    1. When I tick "Enable caching" in page properties for homepage and then click any link on the website it will go to different URL but show content of homepage
    2. Structure of pages is very similar to http://demo.sitefinity.com
    3. I use some custom controls + generic content but if I recall correctly this happened before we introduced custom controls I can test that tomorrow
    4. I cannot replicate this issue on demo.sitefinity
    5. I use Sitefinity 3.7.2096.2:1 I have another website with similar setup on the same server and it works all right :/ I am really confused Slawek
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Jan 2011
    Link to this post
    Hello Slawek,

    I have not seen this issue before and the only thing that I suspect is that you have some cached custom controls which do not update their data. In this cases you should use Cache Substitution Controls. You can try to replicate the issue with some of the built in controls and host the project on another server to see whether the issue will disappear. It is possible that you have enabled some IIS caching.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Slawek
    Slawek avatar
    16 posts
    Registered:
    16 Feb 2009
    14 Jan 2011
    Link to this post
    Hi Ivan,

    I don't think it's custom controls because it happens also on an empty master page. It shows the whole same page for any requested URL not only part.

    I tested on 3 different servers and compared web.config files with the site that's working all right but still no luck.

    What IIS caching are you talking about? I'm on IIS6 how do I check it?

    Thanks,
    Slawek
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Jan 2011
    Link to this post
    Hello Slawek,

    Try moving the project to a local or another server and run it through Visual Studio web server to see whether the issue will persist. Observe the HTTP response and request to see whether there is something that might help.
    You might find this post useful - Flush cache in iis6

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
6 posts, 0 answered