+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Cannot convert from string. Server Error, when editing generic content

Cannot convert from string. Server Error, when editing generic content

13 posts, 1 answered
  1. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    03 Feb 2010
    Link to this post
    Hi

    When i try to edit a generic content I get the follow error

     

    Server Error in '/' Application.

    Cannot convert from string.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: Cannot convert from string.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [InvalidOperationException: Cannot convert from string.]
       Telerik.Cms.Web.UI.Templates.Attribute..ctor(String name, String value, ObjectBuilder builder, PropertyDescriptorCollection properties) +873
       Telerik.Cms.Web.UI.Templates.PropertiesParser.CreatePropertyBuilder(HtmlChunk chunk, PropertyDescriptor propDescr) +194
       Telerik.Cms.Web.UI.Templates.PropertiesParser.ParseOpenTag(HtmlChunk chunk) +160
       Telerik.Cms.Web.UI.Templates.TemplateParser.ParseChunk(HtmlChunk chunk) +43
       Telerik.Cms.Web.UI.Templates.TemplateParser.Parse() +117
       Telerik.Cms.Web.UI.Templates.ObjectBuilder.ParseHtml(TemplateParser parser) +14
       Telerik.Cms.Web.UI.Templates.PropertiesBuilder.ParseHtml(String html) +40
       Telerik.Cms.Web.UI.Templates.TemplateParser.FinalizeCurrentBuilder() +154
       Telerik.Cms.Web.UI.Templates.TemplateParser.ParseCloseTag(HtmlChunk chunk) +61
       Telerik.Cms.Web.UI.Templates.TemplateParser.ParseChunk(HtmlChunk chunk) +219
       Telerik.Cms.Web.UI.Templates.TemplateParser.Parse() +117
       Telerik.Cms.Web.UI.Templates.ObjectBuilder.ParseHtml(TemplateParser parser) +14
       Telerik.Cms.Web.UI.Templates.ObjectBuilder.ParseHtml(String html) +86
       Telerik.Framework.Web.ControlUtils.GetTemplate(String virtualPath, String resourceFileName, Type assemblyInfo, Type localizationAssemblyInfo) +616
       Telerik.Framework.Web.ControlUtils.GetTemplate(String virtualPath, String resourceFileName, Type assemblyInfo, Type localizationAssemblyInfo, Type templateMapType, String additionalTemplateKey) +327
       Telerik.Cms.Web.UI.ViewModeControl`1.CreateLayoutTemplate(Type assemblyInfo, Type localizationAssemblyInfo) +104
       Telerik.Cms.Web.UI.ViewModeControl`1.get_LayoutTemplate() +25
       Telerik.Cms.Web.UI.ViewModeControl`1.get_Container() +39
       Telerik.Cms.Web.UI.ViewModeControl`1.CreateChildControls() +44
       System.Web.UI.Control.EnsureChildControls() +87
       System.Web.UI.Control.PreRenderRecursiveInternal() +44
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842
    


    Its been suggested in other threads that this error is produced when sitefinity is operating in a medium trust enviorment, which my website is. However iwas previously able to edit generic content with no problems

     

     

     

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    03 Feb 2010
    Link to this post
    Hi Christopher Larkin,

    Thank you for using our services.

    Could you please check it the trust settings on your project have been changed. For example if the project has been set to run in full trust but the environment is running in Medium or vise versa.

    All the best,
    Radoslav Georgiev
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  3. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    03 Feb 2010
    Link to this post
    Hi

    I have confirmed that the project has not been modified since i set it up to work in a medium trust enviorment

    Chris
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Feb 2010
    Link to this post
    Hello Christopher Larkin,

    This error should be somewhere in the Generic Content control templates. Please send us these templates so we can test them locally. We have our own template parser which is failing to process the template. 

    Thank you in advance. 

    Best wishes,
    Georgi
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  5. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    05 Feb 2010
    Link to this post
    which email should i send the files to?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 Feb 2010
    Link to this post
    Hello Christopher Larkin,

    Open a bug report and attach the files there with reference to this post. We will see what is going wrong and get back to you in the forum once we have any information.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  7. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    05 Feb 2010
    Link to this post
    It seems i am not allowed to oopen a bug report as i am over the 60 day period
  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Feb 2010
    Link to this post
    Hi Christopher Larkin,

    Could you please upload the template somewhere, and provide us with a download link?

    Sincerely yours,
    Georgi
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  9. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    08 Feb 2010
    Link to this post
    You can get the files here:

    http://www.uat-vida.com/site.zip
  10. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Feb 2010
    Link to this post
    Hello Christopher Larkin,

    Thank you for the files. We have them downloaded and will check the template. You can remove the files from the server. 

    Sincerely yours,
    Georgi
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  11. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    12 Feb 2010
    Link to this post
    Hi,
    been waiting for a while for an update, have you found any errors?
  12. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    15 Feb 2010
    Link to this post
    Hello Christopher Larkin,

    Apologies for the delay. 

    We investigated your project locally, but everything seems to be working just fine - please check the attached screenshot.

    I noticed that you are not using the external templates though. It's strange that you have this error, since we do not have anything which can cause it in the internal template. Still, you can try to map an external template, hopefully this will make a difference. Here is the KB article you need to follow: http://www.sitefinity.com/support/kb/sitefinity-3-x/how-to-map-a-view-to-an-external-template-in-sitefinity-3-6-or-later.aspx

    In the particular case, you should map the following template:

    <viewSettings hostType="Telerik.Cms.Engine.WebControls.Design.GenericContentDesigner"
    layoutTemplatePath="~/Sitefinity/Admin/ControlTemplates/Generic_Content/GenericContentDesigner.ascx" />

    Let us know if you still face the problem after this, together with some screenshots. 

    Thank you.

    Kind regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  13. Christopher Larkin
    Christopher Larkin avatar
    7 posts
    Registered:
    22 Jul 2009
    19 Mar 2010
    Link to this post
    This worked perfeclty, Thanks
Register for webinar
13 posts, 1 answered