+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / default homepage not working quite right after 3.7 .net 4 upgrade

default homepage not working quite right after 3.7 .net 4 upgrade

4 posts, 0 answered
  1. Imran
    Imran avatar
    75 posts
    Registered:
    17 Jan 2007
    19 Oct 2010
    Link to this post
    Before we upgraded using Sitefinity_3_7_2136_dev_NET40_patch, in SF we created a page called Default.aspx. We never had any pages marked as the homepage in the pages admin section. When the root was accessed like this:

    http://localhost/projectname/ or
    http://www.projectname.com

    it loaded this default page that we created in SF. This was all fine.

    Then we applied to the patch to our site. So now when you access the URLs listed above, it says: 

    Thank you for visiting our web site. Please return soon for updates.

    If I mark the default.aspx as the homepage, and access one of those URL's I get the following error:

    Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.

    But if I access the following http://localhost/projectname/default.aspx or http://www.projectname.com/default.aspx, everything works just fine.

    Any idea as to why this maybe happening and how to resolve it ? Many thanks.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2010
    Link to this post
    Hi Imran,

    Do you have any control on your page that uses Session objects? SessionStateModule Class provides session-state services for an application. It writes session data to and retrieves it from the session-state store and raises the Session_OnStart and Session_OnEnd events

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Imran
    Imran avatar
    75 posts
    Registered:
    17 Jan 2007
    19 Oct 2010
    Link to this post
    Hi Ivan

    The default.aspx has a masterpage which uses the Session object. This works fine on every other page, and even on the default.aspx when its accessed directly - just not when a page is not specified.

    I did at various sessions settings into the web.config, but none of these helped either.. 
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2010
    Link to this post
    Hello Imran,

    1. Make sure that System.Web.SessionStateModule is registered

    • To register the module for IIS 6.0 and IIS 7.0 running in Classic mode use the web.config and its httpModules section

    <configuration>
      <system.web>
        <httpModules>


    • Registering the HTTP Module in IIS 7.0 Integrated Mode use web.config and its modules section


    <configuration>
     <system.webServer>
       <modules>


    If you are using IIS7 IngaratedMode you could try adding runAllManagedModulesForAllRequests

    <system.webServer>
            <validation validateIntegratedModeConfiguration="false"/>
        <modules runAllManagedModulesForAllRequests="true">


    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered