+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Deleting movie in RAD editor leaves object

Deleting movie in RAD editor leaves object

3 posts, 0 answered
  1. Darren
    Darren avatar
    72 posts
    Registered:
    19 Mar 2008
    30 Jun 2008
    Link to this post
    Is there a bug in the RAD editor with regards to deleting movies?
    I noticed that when I delete movies from the generic content control the movie reference is deleted but the object remains so I have to clean it out in html view.

    Is this a known bug with a work around?
  2. Darren
    Darren avatar
    72 posts
    Registered:
    19 Mar 2008
    01 Jul 2008
    Link to this post
    OK, it appears this is a feature of the RAD editor since I've tried this in different versions of the Telerik ASP.NET toolkit and get the same behavior.
    I also get the same effect with links where I can create a link then select the link and delete only to find the link markup is still there but the text has gone. To work around this you have to choose the link, unlink then delete which are extra steps than should really be needed.

    I think I'll raise this against the Telerik control kit as a possible future change, better support for cleaning up markup post deleting items on the page. If all the text is deleted then it should probably be inferred that the link is no longer needed and can be deleted.
    Equally when deleting a video the object should go as well.
  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    02 Jul 2008
    Link to this post
    Hello Darren,

    We managed to replicate this issue. It is browser specific and occurs in Firefox only, because when you click on the movie in the editor, you select only the <embed> tag, while the <object> remains unselected. The case with the links is similar to this one.

    These issues will be fixed by our RadControls team as soon as possible.

    We have updated your Telerik account for drawing our attention to this.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
3 posts, 0 answered