+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Documents Problems

Documents Problems

21 posts, 0 answered
  1. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    07 Mar 2008
    Link to this post

    I am having trouble with the documents module.  Whenever I try to click on one of my documents to download it I get an error stating that it can not find the file.  I have even tried removing all of the underscores in my file names and I still have this problem.

    To move along on my project, I decided to upload the documents to the file structure using the file upload section "Files".  I was able to create a new directory and then upload the files, but I got the following error:

    Access to the path 'C:\Inetpub\WebDirectory\SiteName\Files\Forms' is denied.

    This is a really odd error since I am using an IP Address for the building of this site.

    Please advise.
  2. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    07 Mar 2008
    Link to this post
    More Issues

    When I am working in the generic content control and I select the text that I want to use for my link (for example "My Document") and then I click on insert document icon I am having the following problems.

    1) If I select the document it replaces the text that I highlighted (My Document) with the name of the document - mydoc.pdf.

    2) If I try to select the document from my library that I have already created with the Documents & Images module, I get an server error unless I turn off "RemoteOnly" and then turn it back on.  REALLY ODD.  It does however fix my first problem above.
  3. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    07 Mar 2008
    Link to this post
    Sorry to keep on rambeling -

    Regaring problem #2 fixing problem #1 - when I select a document from my library and save my file and then try to view it on my public site, I get a page can not be found error and the url looks like:
    Libraries/Directory/Form+Name.sflb
  4. Tihomir
    Tihomir avatar
    53 posts
    Registered:
    24 Sep 2012
    10 Mar 2008
    Link to this post
    Hi medicalwebgeek,

    In order to be able to download files, see images and thumbnails in the Documents & Images module, you should set the ISAPI mappings for .sflb and .tmb extensions on your IIS virtual directory. These should be set automatically by the Sitefinity installer, however, you need to add them manually if you have upgraded using the patch.

    Let us know if this fixes your problems.

    Best wishes,
    Tihomir
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    10 Mar 2008
    Link to this post
    Hi medicalwebgeek,

    Please register the ContentHttpHandler handler for the .tmb and .sflb extensions in the application web.config as well:

        <httpHandlers>
          <add verb="GET" path="*.sflb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" />
          <add verb="GET" path="*.tmb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" />
       </httpHandlers>

    All the best,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    14 Mar 2008
    Link to this post
    I am still getting the following error:
    Server Error in '/' Application

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /Libraries/2008+Minutes/02-06-2008.sflb


    I have added the mapping and confirmed that my web config is correct.

    Please advise.

  7. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    14 Mar 2008
    Link to this post
    Hi medicalwebgeek,

    Another thing we forgot to mention is that we found a major issue when you set your application as a default web site or you are using Web Application Project. That is when your application name is "/". This issue is already fixed and will be shipped with the upcoming service pack. We are sorry for the inconvenience caused. We hope this does not cost you a lot.

    Please, let us know if you think the problem might hide somewhere else.

    Kind regards,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    14 Mar 2008
    Link to this post
    Is there anything that I can do in the mean time?  I have two projects that are about to go live this upcoming week.
  9. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    14 Mar 2008
    Link to this post
    Hello medicalwebgeek,

    The only solution I can think of is to change your project application name to something different from "/". That is, the code bellow should not return the "/" value:

    HostingEnvironment.ApplicationVirtualPath  

    I am really sorry for this big inconvenience, please let us know if the solution above would do the job.

    Perhaps another solution would be to modify the item URLs in the database once the upload of images and documents is finished. I am not completely sure this would solve the problem since I have not tested it yet.


    Greetings,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  10. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    14 Mar 2008
    Link to this post
    Can you send me the script for the last solution?  What will I have to do once you fix the issue with the SP? 

    Regarding the Service Pack - what is your go live date with that?  I saw on one board the 20th of March.

    Please advise.
  11. Daniel L
    Daniel L avatar
    26 posts
    Registered:
    06 May 2006
    15 Mar 2008
    Link to this post
    I'm having this same issue. When do you expect to release a fix for this? it poses a very serious problem because now we can't use the Images & Documents module when it's hosted on the domain. Do you have any better workarounds or a patch we can install?

    Thanks,
    Daniel
  12. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    17 Mar 2008
    Link to this post
    Hi medicalwebgeek and Daniel L,

    Unfortunately, modifying the database would not do the job but the problem might be overcome by creating a new HttpHandler. For this approach there will be another problem - it would not be easy to override the handler in an appropriate manner. Because of this, I have attached the complete fixed code of the handler.

    All you need to do is put that code either in a new code project or in the App_Code folder and modify the web.config file so that the old handler references should now point to the new. Hope this would help. Let us know if you have problems applying the code that I sent.

    Best wishes,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  13. Daniel L
    Daniel L avatar
    26 posts
    Registered:
    06 May 2006
    18 Mar 2008
    Link to this post
    Thanks Vassil! This is VERY helpful.
  14. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    21 Mar 2008
    Link to this post
    What code should I modify in hte webconfig under HTTPHandlers?

    Can you supply the code?
  15. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    21 Mar 2008
    Link to this post
    Hi medicalwebgeek,
    In case you use the new CustomHttpHandler that Vassil provided earlier, these should be the changes in your web.config file.

    <httpHandlers>  
    .  
    .  
    <add verb="GET" path="*.sflb" 
          type="ContentHttpHandlerFixture.ContentHttpHandlerFix" />  
    <add verb="GET" path="*.tmb" 
        type="ContentHttpHandlerFixture.ContentHttpHandlerFix" />  
    .  
    .  
    </httpHandlers>  


    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  16. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    21 Mar 2008
    Link to this post
    Do I need to update my project to use Asp 3.0?  He has a reference to Linq in the code file.

    using System.Linq;

  17. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    21 Mar 2008
    Link to this post
    Hi medicalwebgeek,

    You can safely remove this reference.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  18. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    22 Mar 2008
    Link to this post
    I am also getting this error when I try to batch edit names:

    The object belongs already into a different transaction 

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Nolics.ORMapper.Base.NolnetException: The object belongs already into a different transaction

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [NolnetException: The object belongs already into a different transaction] Nolics.ORMapper.Base.OdbClassHelper.JoinTransaction(IOdbClass cl, Transaction tran, Transaction& curTransaction, OdbObjectStates& state) +376 Telerik.Versioning.Data.VersionItem.Nolics.ORMapper.Base.IOdbClass.Join(Transaction tran) +16 Nolics.ORMapper.Base.Transaction.Join(IOdbClass mem) +75 Telerik.Versioning.Data.DefaultProvider.CommitChanges(Guid id, CultureInfo culture) +389 Telerik.Versioning.VersionManager.CommitChanges(Guid id, CultureInfo cuture) +40 Telerik.Cms.Engine.ContentManager.PublishContent(StagedContent staged) +374 Telerik.Cms.Engine.ContentManager.SaveContent(IContent content) +340 Telerik.Libraries.WebControls.Admin.BatchEditor.Button_Command(Object sender, CommandEventArgs e) +916 System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +105 System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +132 System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +7 System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +11 System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +177 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1746

  19. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    24 Mar 2008
    Link to this post
    Hello medicalwebgeek,

    Well, we are not able to replicate this behavior. Do you see it every time when you "batch edit" your library items?
    Such exception may occur if you click the Save button and while loading press F5 to refresh the page.

    Could you elaborate a little more?

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  20. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    26 Mar 2008
    Link to this post
    It might be a Community Edition problem (playing around with that) or a SQL Express problem.  I have not had it happen with my standard version or SQL 2005.
  21. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    28 Mar 2008
    Link to this post
    Hello medicalwebgeek,

    Thank you for your additional information. We will continue to investigate this issue and try to reproduce it.
    Don't hesitate to contact us if your problems persist and you have more information.

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
21 posts, 0 answered