+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Embedded video

Embedded video

5 posts, 0 answered
  1. Mike Davis
    Mike Davis avatar
    5 posts
    Registered:
    25 May 2010
    29 Mar 2011
    Link to this post
    Hi All,

    A client of ours is using the Generic Content Control to embed Britecove videos on the page.  That works fine, but when she returns to the page for edits,  the embedded video code disappears as soon as she goes into edit mode.  Then she has to find the code and re-insert.

    Any help you can give is appreciated.

    Thanks.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    01 Apr 2011
    Link to this post
    Hello Mike,

    It is possible that there is some filter that strips your video

    1. Please send the code that you use to inject the video
    2. Please tell me the build version of Sitefinity you use

    http://www.sitefinity.com/support/kb/sitefinity-3-x/how-to-check-your-current-sitefinity-version.aspx

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  3. Mike Davis
    Mike Davis avatar
    5 posts
    Registered:
    25 May 2010
    01 Apr 2011
    Link to this post
    Thanks for the reply.  Following is the Sitefinity version our client is running:
    Sitefinity 3.7.2096.2:1

    Following is the embedded video code on the page:

    <!-- Start of Brightcove Player -->
    <div style="display: none;"></div>
    <!-- By use of this code snippet, I agree to the Brightcove Publisher T and C  found at https://accounts.brightcove.com/en/terms-and-conditions/.  -->
    <script language="JavaScript" type="text/javascript" src="http://admin.brightcove.com/js/BrightcoveExperiences.js"></script>
    <
    object class="BrightcoveExperience" id="myExperience">
    <param name="bgcolor" value="#FFFFFF" /> <param name="width" value="252" /> <param name="height" value="459" /> <param name="playerID" value="822848435001" /> <param name="playerKey" value="AQ~~,AAAAr1aSwNk~,oPvmwVf0IrV9UfhcZm-32XvvOp6FlQCF" /> <param name="isVid" value="true" /> <param name="isUI" value="true" /> <param name="dynamicStreaming" value="true" /> </object>
    <!--  This script tag will cause the Brightcove Players defined above it to be created as soon as the line is read by the browser. If you wish to have the player instantiated only after the rest of the HTML is processed and the page load is complete, remove the line. -->
    <script type="text/javascript">brightcove.createExperiences();</script>
    <!-- End of Brightcove Player -->
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Apr 2011
    Link to this post
    Hello Mike,

    Can you remove the following line from the code you are adding in the HTML area of the RadEditor

    <script language="JavaScript" type="text/javascript" src="http://admin.brightcove.com/js/BrightcoveExperiences.js"></script>


    and try to edit the item.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

  5. Mike Davis
    Mike Davis avatar
    5 posts
    Registered:
    25 May 2010
    05 Apr 2011
    Link to this post
    Problem solved.

    Thank you very much.
Register for webinar
5 posts, 0 answered