+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error 404 with RSS in iis7

Error 404 with RSS in iis7

4 posts, 0 answered
  1. Chris
    Chris avatar
    10 posts
    Registered:
    30 Apr 2008
    01 May 2008
    Link to this post

    Troubleshooting for Error 404 with RSS only gives a fix for iis6 - what should I do to solve the issue on iis7?

    Have tried to add mappings as described for iis6 but with no success.

    Also have this in web.config
     
    <httpHandlers>
    ...
               <add verb="*" path="*.rss" type="Telerik.Rss.RssHttpHandler, Telerik.Rss"/>

    This is error:

    HTTP Error 404.0 - Not Found

    Description: The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    Error Code: 0x80070002

    Notification: MapRequestHandler

    Module: IIS Web Core

    Requested URL: http://localhost:80/test.rss

    Physical Path: C:\inetpub\20080401_Web\test.rss

    Logon User: Anonymous

    Logon Method: Anonymous

    Handler: StaticFile


    Any help appreciated.,..

  2. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    01 May 2008
    Link to this post
    Hello Chris,

    please apologize us for not providing IIS 7 workaround in our documentation. Here is what you need to do:

    1. Open IIS 7
    2. Select your website from the left pane
    3. Double-click on the Handler Mappings in the right panel (IIS group)
    4. Click on the Add Script Map
    5. type "*.rss" in the Request Path textbox (without the quotation marks)
    6. in the Executable textbox paste the same value you have in the Executable textbox for *.asmx (I am sorry you'll have to close the window by clicking on cancel now and find the *.asmx extension, click on edit and copy the text from Executable textbox)
    7. Start from the step 4 and enter the *.rss and executable
    8. Type RSSMapping (or whatever you prefer) in the Name textbox
    9. Click on Request Restrictions
    10. Clear the checkbox in the Mapping tab ("Invoke the mapping handler only if request is mapped to")
    11. Switch to Verbs and make sure that the All Verbs checkbox is checked
    12. Click OK
    13. Click OK again
    14. Click Yes if prompted
     
    The RSS on your site should be working now. I apologize if the walkthrough is not the most concise, but I've tried to make it as simple as possible. Let me know if you have any additional questions.


    All the best,
    Ivan
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Chris
    Chris avatar
    10 posts
    Registered:
    30 Apr 2008
    02 May 2008
    Link to this post
    That worked - thanks for the prompt response...
  4. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    02 May 2008
    Link to this post
    Hello Chris,

    I am very glad that it worked. Thank you for your patience and understanding.

    Regards,

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered