+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Error While Indexing

Error While Indexing

4 posts, 0 answered
  1. Jon Ingersoll
    Jon Ingersoll avatar
    32 posts
    Registered:
    12 May 2009
    26 Apr 2010
    Link to this post
    Our indexing is running slowly, an examination of the sitefinity log while it's running shows that some of our pages are throwing:

    Exception Type: System.NullReferenceException
     
    Message: Object reference not set to an instance of an object.
     
    Source: App_Web_h0xkivat
     
    Stack Trace:
       at edu.yale.som.sitefinity.membership.MemberDisplay.Page_Load(Object sender, EventArgs e)
       at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
       at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
       at System.Web.UI.Control.OnLoad(EventArgs e)
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Control.AddedControl(Control control, Int32 index)
       at System.Web.UI.ControlCollection.Add(Control child)
       at Telerik.Cms.Web.InternalPage.AddPageControls(IPageContent pageContent, Dictionary`2 placeHolders)
       at Telerik.Cms.Web.InternalPage.CreateChildControls()
       at System.Web.UI.Control.EnsureChildControls()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    We've never seen this error before and don't believe it to be coming from any of our custom controls, is a Sitefinity control throwing this? kivat appears to be "nice" in finnish.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    26 Apr 2010
    Link to this post
    Hello Jon Ingersoll,

    The last line that is called before throwing "Object reference " comes from Page_Load of
    edu.yale.som.sitefinity.membership.MemberDisplay.Page_Load. This is a NullReferenceException and most probably you have some object that is null when Page_Load is called. You are trying to use a reference variable who's value is null. Try removing the controls from the problematic page and from its master one by one. Check the Page_Load events of the controls as well.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jon Ingersoll
    Jon Ingersoll avatar
    32 posts
    Registered:
    12 May 2009
    26 Apr 2010
    Link to this post
    A further look does show that it's one of our controls, but that Web_App_h0xkivat isn't from our code, is that an error from some underlying Sitefinity code that we are extending?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    26 Apr 2010
    Link to this post
    Hi Jon Ingersoll,

    This looks like some temp file that is generated. I suggest that you should verify the code from your control. You could run the VS debugger during indexing to see what exactly is going wrong. Quck fix is excluding the code from the crawler

    if (!CmsContext.IsRequestCrawler(this.Context))
    {
      // do your logic here
    }


    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
4 posts, 0 answered