Try Now
More in this section

Forums / Bugs & Issues / Extensionless URLs.... again

Extensionless URLs.... again

2 posts, 0 answered
  1. Eric
    Eric avatar
    4 posts
    13 Jun 2011
    06 Nov 2011
    Link to this post
    Hi All,

    I've taken a look through the forums and have found several areas that address this issue.  And after mucking around with it for awhile now, I figure I should put out a bit of a distress thread.
    From the looks of a few threads, it should simply work after blanking out the pageExtension attribute in cms defaultProvider node.

    <cms defaultProvider="Sitefinity" pageExtension="" projectName="blah"...../>

    After trying to do so, I simply get a 404.  Even after trying to enable the sf404.aspx..... it still doesn't work.

    The current version that I'm working on is 3.7.2096.2:1
    Should it be working?  If so are there any hints or places I should be looking at?

    Or should I try to upgrade to the latest service pack and then try again?

    It's also been noted that it may not work if my sitefinity site is set as a web application instead of a virtual directory....can someone verify this?   I've tried it both ways with the same result.

    Any help is appreciated.

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    09 Nov 2011
    Link to this post
    Hello Eric,

    Can you please show us how are you setting the sf404.aspx? Are you setting it in web.config custom errors or in IIS? It depends where you set it, for example if you set this through IIS it matters if your project is in the root of if it is added as an application under another site. In this case you must set the path as /VirtualDirectoryName/sf404.aspx. Furthermore this setting is set to serve extensionless urls when your page extension is aspx. Since you are not using an extension then you should also cut the extension from the sf404 page.

    However since you are on Sitefinity 3.7 it is recommended that you run your website in IIS 7.0 Integrated pipeline mode. Then instead of using the sf404.aspx (this one is developed for IIS 6.0), you should add a wildcard script handler mapping to aspnet_isapi.dll.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered