+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Extensionless URLs in 3.7 SP4

Extensionless URLs in 3.7 SP4

2 posts, 0 answered
  1. Kerchal
    Kerchal avatar
    4 posts
    Registered:
    14 Apr 2011
    21 Apr 2011
    Link to this post
    I am currenty trying to get the extentionless url working on Windows 7 Ultimate machine. I installed Sitefinity_3_7_2136_standard_trial_NET40.exe on my local IIS (IIS 7). I have to convert a site that used Sitefinity 3.2 to SiteFinity 3.7 (.Net 4.0). The applications works whenever a URL is sent with the .aspx extension. However, when I remove the pageExtension (  <cms defaultProvider="Sitefinity" pageExtension="" projectName="Store" disabled="false" pageEditorUIMode="Overlay">), I receive the "HTTP Error 404.0 -Not Found" error . This is how the httpErrors section appears in the web.config:

        <httpErrors errorMode="DetailedLocalOnly" defaultPath="/sf404.aspx" defaultResponseMode="ExecuteURL">
          <remove statusCode="404" subStatusCode="-1" />
          <remove statusCode="500" subStatusCode="-1" />
          <error statusCode="404" prefixLanguageFilePath="" path="/sf404.aspx" responseMode="Redirect" />
          <error statusCode="500" prefixLanguageFilePath="" path="/500.aspx" responseMode="Redirect" />
        </httpErrors>

    I also have the modules set tp "runAllManagedModulesForAllRequests" set to true:

      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules runAllManagedModulesForAllRequests="true">

    I have attached screen shots of my IIS settings of the Handler Mappings and Error Pages.

    Thanks,

    Kerchal



  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    09 Dec 2016
    27 Apr 2011
    Link to this post
    Hi Kerchal,

    Can you, please, tell me if the issue reproduces with newly created pages as well or on a new blank project? Generally just by changing the pageExtension=".aspx" to pageExtension="" in the web.config <cms> tag should work just fine, and your pages should be extensionless - can you try testing only with this setting? Also, can you make sure you are not specifying any additional URLs for your page that are extensionless already, e.g. you have ~/MyPage.aspx, but you have specified additional URL of ~/MyPage, since this might create confusion.

    Regards,
    Boyan Barnev
    the Telerik team

2 posts, 0 answered