+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Generic Content - Image Link Issue

Generic Content - Image Link Issue

3 posts, 0 answered
  1. Drew
    Drew avatar
    16 posts
    Registered:
    19 Sep 2008
    27 Feb 2009
    Link to this post
    Hello,

    When I insert an image into a generic content editor and then wrap a link around the image using the insert link button the url is not forming correctly.  I am selecting a page to link from and the address in the textbox looks like this "~/SomeDirectory/SomePage.aspx".  If I publish and view the page, the url gets rewritten to this "http://www.my-domain/~/SomeDirectory/SomePage.aspx".  Obviously, this is not good.  Am I missing something simple, or is this a bug.  We are using SF 3.5 on this website.  Any information is greatly appreciated.

    Thanks,
    -Drew
  2. Drew
    Drew avatar
    16 posts
    Registered:
    19 Sep 2008
    27 Feb 2009
    Link to this post
    Typo: the URL gets rewritten to "http://www.my-domain.com/~/SomeDirectory/SomePage.aspx"

    -Drew
  3. Sonya
    Sonya avatar
    231 posts
    Registered:
    24 Sep 2012
    03 Mar 2009
    Link to this post
    Hello Drew,

    This is a bug in Sitefinity 3.5 . It is fixed for 3.6 where dynamic links are used. There, the URL address no longer looks like the following (3.5)
                ~/Home.aspx
    but it is now in the following format (3.6)
                [Sitefinity]c4ed7e8d-0410-442e-be25-16c14f46cfb9

    This passes the ID of the page instead of its relative path.

    Our recommendation is to upgrade to Sitefinity 3.6 (Hotfix) in order to be able to fully use this functionality.

    Kind regards,
    Sonya
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
3 posts, 0 answered