+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Generic content localization Issue

Generic content localization Issue

14 posts, 1 answered
  1. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    27 Aug 2010
    Link to this post

    Hi,
    I have enabled localization for the Generic content module and entered data for both English and arabic languages where english was my default language. When the default language is changed to Arabic, the arabic content is replaced by the english content the english content disappeared making a mess in my website.(See attached screenshot)

    Is there something I can do fix the issue? Please help, its urgent.


    Thanks
    Fadi

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 Aug 2010
    Link to this post
    Hi Fadi Raheel,

    How did you switch the default language? It looks like you have changed it from the web.config which has cased the issues. You could take a look at this KB

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    30 Aug 2010
    Link to this post
    Hi Ivan,

    i modified the tables as described in the KB but that didn't fix my issue. Is there anything missing in the code below?

    update sf_CmsPageContent set LangID = 9 where LangID=127
    update sf_CmsPageContent set LangID = 127 where LangID=1
      
    update sf_StagedPageContent set LangID = 9 where LangID=127
    update sf_StagedPageContent set LangID = 127 where LangID=1
      
    update sf_GCMetaData set LangID = 9 where LangID=127
    update sf_GCMetaData set LangID = 127 where LangID=1
      
    update sf_CmsContentVersion set LangID = 9 where LangID=127
    update sf_CmsContentVersion set LangID = 127 where LangID=1
      
      
      
    update sf_PageContentBase set LangID = 9 where LangID=127 and not id in (select id from sf_CmsTemplContent)
    update sf_PageContentBase set LangID = 127 where LangID=1 and not id in (select id from sf_CmsTemplContent)
      
    update sf_CmsCtrlLinks set LangID = 9 where LangID=127 and not PageID in (select id from sf_CmsTemplContent)
    update sf_CmsCtrlLinks set LangID = 127 where LangID=1 and not PageID in (select id from sf_CmsTemplContent)

    Thanks
    Fadi
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    03 Sep 2010
    Link to this post
    Hi Fadi Raheel,

    We have responded to you in another thread with a similar problem. Did you manage to resolve it by following the instructions there?

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    06 Sep 2010
    Link to this post

    I didn't get your answer. could you please send me the link.

    Thanks
    Fadi

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    06 Sep 2010
    Link to this post
    Hi Fadi Raheel,

    Here is a list of the tables that you have to update. It looks like you are missing some of them in the script you have.

    • sf_PageContentBase
    • sf_CmsPageContent
    • sf_StagedPageContent
    • sf_CmsCtrlLinks
    • sf_GCMetaData
    • sf_CmsContentVersion
    • sf_CmsTextContent
    • sf_VersionItem
    • sf_VrsTxtData

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    17 Sep 2010
    Link to this post

    I updated the script to include the missing tables and that changed my default language but another issue came up, when i update any template/page it floats with duplicates making a mess in the pages. This occurs every time I click the publish button even if no changes are done on the template/page.

    You can download a recorded video of the issue from: http://www.TestDriveYourWebsite.com/video.rar

    Thanks

    Fad

  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Sep 2010
    Link to this post
    Hi Fadi Raheel,

    This issues does not look related to the localization. Could you check whether you have some code that adds the menu. Also, this issue appears only for this  - SiteMenu control and non of the other controls on your page is duplication. Try also removing the control from the template and then add it again..

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    17 Sep 2010
    Link to this post
    Hi Ivan,

    This issue didn't happen before running the script. I am not adding the controls by code and the issue happens for the SiteMenu, the language selector and the Search box (see video) and every other control added from the toolbox on the templates. The same is true for controls added to pages as showed in the video.

    Thanks
    Fadi
  10. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    17 Sep 2010
    Link to this post
    I also tried removing all added controls from the template/page and re-adding them but i got the same issue.

  11. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Sep 2010
    Link to this post
    Hi Fadi Raheel,

    You have made manual changes to the database and I cannot tell you what you have broken. You can open a support request and send the project and its database backup to us. We will set the project and try to find what is causing this issue.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
    21 Sep 2010
    Link to this post

    The only changes i made to the database was according to your instructions.

    update sf_CmsPageContent set LangID = 9 where LangID=127 
    update sf_CmsPageContent set LangID = 127 where LangID=1 
        
    update sf_StagedPageContent set LangID = 9 where LangID=127 
    update sf_StagedPageContent set LangID = 127 where LangID=1 
        
    update sf_GCMetaData set LangID = 9 where LangID=127 
    update sf_GCMetaData set LangID = 127 where LangID=1 
        
    update sf_CmsContentVersion set LangID = 9 where LangID=127 
    update sf_CmsContentVersion set LangID = 127 where LangID=1 
        
        
        
    update sf_PageContentBase set LangID = 9 where LangID=127 and not id in (select id from sf_CmsTemplContent) 
    update sf_PageContentBase set LangID = 127 where LangID=1 and not id in (select id from sf_CmsTemplContent) 
        
    update sf_CmsCtrlLinks set LangID = 9 where LangID=127 and not PageID in (select id from sf_CmsTemplContent) 
    update sf_CmsCtrlLinks set LangID = 127 where LangID=1 and not PageID in (select id from sf_CmsTemplContent)
      
      
    update sf_CmsTextContent set  Culture = 9 where Culture=127 
    update sf_CmsTextContent set Culture = 127 where Culture=1 
      
    update sf_VersionItem set CultureID = 9 where CultureID=127 
    update sf_VersionItem set CultureID = 127 where CultureID=1 
      
    update sf_VrsTxtData set CultureID = 9 where CultureID=127 
    update sf_VrsTxtData set CultureID = 127 where CultureID=1
  13. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Sep 2010
    Link to this post
    Hello Fadi Raheel,

    These are some scripts that we have provided in another thread, but reviewing the history of this thread show shat you have not use it properly and you have not updated all required tables. Could you send the database and sample project to us? I do not see another option to resolve this issue with the information your are providing.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  14. xor
    xor avatar
    42 posts
    Registered:
    04 Jan 2010
Register for webinar
14 posts, 1 answered