+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Getting 404

Getting 404

10 posts, 0 answered
  1. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    26 Jul 2009
    Link to this post
    Hi,

    I am getting 404's in sitefinity/admin/Pages.aspx when I select a page under the sitemap in the right pane.
    See the 2 links below for images.

    http://victory.net.nz/1.jpg

    http://victory.net.nz/2.jpg

    Its like SF doesn't think the pages exist.

    Thanks
  2. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    26 Jul 2009
    Link to this post
    I found a thread that mentioned to add the following to web.confg

    <add verb="GET" path="*.sflb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" />
            <add verb="GET" path="*.tmb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine" </httpHandlers>

    I thought though this was not required with a s.6 sp2 application???

    I didn't fix the problem..
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    27 Jul 2009
    Link to this post
    Hi sam,

    The handlers you are referring are related to images and documents where we use sflb extension for Content Items. You can check whether you cave the following handler

     <add name="SitefinityTemplate" path="*.template" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="Script" preCondition="classicMode,runtimeVersionv2.0,bitness32"/> 

    although you are not supposed to register it manually.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  4. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    27 Jul 2009
    Link to this post
    Hi Ivan,

    I have those web.config lines..

    Could you login and check it out:
    username: test pwd: test

    http://intelligentdesign.co.nz/sitefinity/admin/default.aspx


  5. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    27 Jul 2009
    Link to this post
    Any ideas?

    Because of this error I can't save page changes or cancel out of pages.

    Should I move web hosts??????????????????????????????????????????????????
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    28 Jul 2009
    Link to this post
    Hello Sam,

    Is this project working on your local machine? Perhaps the hosting does not have even the standard ASHX handlers. Please try it on another one, and ask the hosting if it has the standard ISAPI things mapped - .master, .ashx

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  7. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    29 Jul 2009
    Link to this post
    My host said he has put the filters in but it is still acting up.

    I can see .ashx files are working as I have images on:
    http://intelligentdesign.co.nz/Projects.aspx

    What test urls can I give him to prove the other filters have been applied??

    What else maybe causing the 404s???
  8. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    29 Jul 2009
    Link to this post
    Ok, hosting support has sorted this now. They were blocking some other filter type.. I will post back later what they did..

    Thanks alot!
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Jul 2009
    Link to this post
    Hi Sam,

    I am very glad to hear it.
    I think that your posting will be helpful for other people experiencing this problem.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  10. sam
    sam avatar
    102 posts
    Registered:
    31 Jan 2008
    29 Jul 2009
    Link to this post
    ok, to help others:
     
    I had support remove URL Scan Filter for my website in IIS as those long URL's were being rejected by it.
Register for webinar
10 posts, 0 answered