+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / how to remove default page from sitefinity cms cms

how to remove default page from sitefinity cms cms

4 posts, 0 answered
  1. andreas
    andreas avatar
    2 posts
    Registered:
    17 Jun 2011
    23 Jun 2011
    Link to this post
    Hi 
    I am working on a website on this site i dont want to set a default page (www.test.com/default.aspx)
    i want something pretty straight forward like www.test.com instead of www.test.com/default.aspx.

    how i can do this.i am using site finity cms ver 3.7

    i will really appreciate your help thanks and regards,
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Jun 2011
    Link to this post
    Hello andreas,


    Login to the back-end and go to the Pages section. There set  a  home page for your website. Then add the highlighted attribute to your web.config

    <cms defaultProvider="Sitefinity" pageExtension=".aspx" siteTemplate="" projectName="MySite" disabled="false" pageEditorUIMode="Overlay" redirectToHomePage="false">

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Brook
    Brook avatar
    14 posts
    Registered:
    27 Oct 2009
    26 Sep 2011
    Link to this post
    I am trying to accomplish removing the defined home page from my URL when the site is initially hit (home.aspx) and have found at least two posts with directions on how to accomplish this, neither seems to work. 

    First Post instructed I should add an empty .aspx file with the same name as my CMS defined homepage to the site root and then defined the default page for the site in IIS 7 as the same file.   

    I also added the redirect property to the web.config (<cms defaultProvider="Sitefinity" pageExtension=".aspx" siteTemplate="" projectName="MySite" disabled="false" pageEditorUIMode="Overlay" redirectToHomePage="false">) per another post.

    Each time I try to access the site using the url http://www.mysite.com I still get http://www.mysite.com/home.aspx instead of http://www.mysite.com  

    What am I missing ? 

    Using Sitefinity 3.7.sp4 (standard).
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    27 Sep 2011
    Link to this post
    Hello Brook,

    It is possible that the IIS default document makes some redirect. You can try to rename your home page to something like "mytesthome" and see whether there will be a difference. If you run the website under development environment do you have problems with redirect to index.aspx? Please set the index.aspx as a home page from the backend of the cms. It is possible that some data is not updated after modifications made to the website.



    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered