+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Invalid Content ID Specified Adding Videos

Invalid Content ID Specified Adding Videos

3 posts, 0 answered
  1. andersleet
    andersleet avatar
    155 posts
    Registered:
    03 Jun 2009
    16 Jul 2009
    Link to this post
    Ok, this is what I did in order to get this error:

    I had a Video Library named 'Appointments'. It had some videos uploaded, but they were not silverlight compatible WMVs so I recreated them to be compatible. Instead of re-uploading each video, I deleted the library (deleting the old videos) and recreated it with the same name. After adding all of the new videos again, I get this:


    And then when I try to click on the (broken) image or the title, I get the following error:

    Invalid content ID specified

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    Exception Details: System.ArgumentException: Invalid content ID specified
    Source Error: 
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 
    [ArgumentException: Invalid content ID specified]
       Telerik.Cms.Engine.WebControls.ContentView.CreateSingleContent() +2928
       Telerik.Cms.Engine.WebControls.ContentView.CreateChildControls() +4649
       Telerik.Libraries.WebControls.VideoBase.CreateChildControls() +21
       System.Web.UI.Control.EnsureChildControls() +87
       System.Web.UI.Control.PreRenderRecursiveInternal() +44
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842

    What can I do to fix this error, and what is causing it?

    Regards,
    anders

  2. andersleet
    andersleet avatar
    155 posts
    Registered:
    03 Jun 2009
    16 Jul 2009
    Link to this post
    I got up and walked away, and when I came back everything is working. Is this an issue with caching?

    Regards,
    anders
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jul 2009
    Link to this post
    Hello andersleet,

    The problem seems to be related to cache. If you remove and add the control again and set its properties there will not be a problem.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
3 posts, 0 answered