+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Lost ability to editin classic and overlay mode.

Lost ability to editin classic and overlay mode.

4 posts, 0 answered
  1. HRC
    HRC avatar
    44 posts
    Registered:
    16 Mar 2009
    15 Jan 2010
    Link to this post
    After applying styles, scripts and images to the templates in my site, i've lost the ability to edit the content.
    I'm able to get as far as having a page in edit mode, however clicking the edit link in either overlay or classic mode produces the following JS error:

    f is undefined
    http://localhost:32980/ScriptResource.axd?d=NLINkePCswFwl7kuvRvT--gtL6nYhD8xqzQ9kX41g2_g3xvv1JR1hSCRkzCKVz-5NX7MQ1-v_Lm33k_688SzGQ2&t=ffffffffd9c2e256
    Line 35

    and the code it fails on is:

    window.radopen=function(e,d){var f=GetRadWindowManager();
    return f.open(e,d)

    I'm hoping someone can shed some light on this.
    There's nothing in the templates that i haven't successfully used before in other sitefinity projects (jquery, swfobject etc.)
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    15 Jan 2010
    Link to this post
    Hi iStudio,

    GetRadWindowManager - returns a reference to the window manager. Check whether you have RadWindow somewhere on your page or in the template. Also make sure that there are not any other js errors thrown. Generally if you have any js errors thrown in page edit mode this could break the backend and controls editing.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Mike Badgley
    Mike Badgley avatar
    4 posts
    Registered:
    01 Oct 2009
    15 Jan 2010
    Link to this post
    Was able to determine the issue behind this. On the site, there are two RadControls being utilized - RadTabStrip and RadTreeView. In both cases, I had set the EnableEmbeddedScript property to False. Doing this caused a few JavaScript errors on both the front and back end to appear. When I set this value back to True, the JavaScript errors went away and we were able to edit in both classic and overlay modes.

    A bit of a strange one...
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jan 2010
    Link to this post
    Hi Mike Badgley,

    You should set EnableEmbeddedScript to false only in case you have needed scripts to replace the basic functionality of the controls you are modifying. You may find the following article useful - Disabling embedded resources.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
4 posts, 0 answered