+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / More Sitefinity instances on the same machine

More Sitefinity instances on the same machine

7 posts, 0 answered
  1. Nicola Achille
    Nicola Achille avatar
    4 posts
    Registered:
    20 Jan 2010
    17 Jun 2011
    Link to this post
    Hi,
    on my production server are running two instances of Sitefinity, with the first version and the second version 3.7sp2 3.7sp1. The server runs IIS 7 and SQL Server 2008.
    About two days ago, suddenly, the second stopped to work. Now this site no longer respond to client calls, which falls into timeout.
    We may have problems with multiple instances of Sitefinity on the same machine?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jun 2011
    Link to this post
    Hi Nicola,

    Please check Sitefinity log file in App_Data/sitefinity.log, IIS log file and SQL server log for related errors.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Nicola Achille
    Nicola Achille avatar
    4 posts
    Registered:
    20 Jan 2010
    17 Jun 2011
    Link to this post
    Hi, thank you for your response.
    We
    analyzed all logs but does not provide us with useful information. In addition, both the IIS logs and the Sitefinity log in AppData is not updated since the site is down.
    There are potential problems of coexistence of two versions of Sitefinity on the same IIS on the same machine?
    Thank you,
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jun 2011
    Link to this post
    Hello Nicola,

    Running two or more projects on the same machine could not be a problem. Are they nested applications or each of them is hosted under different website? If you move the applications on a local machine are there issues?

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Nicola Achille
    Nicola Achille avatar
    4 posts
    Registered:
    20 Jan 2010
    17 Jun 2011
    Link to this post
    None. The strange thing is this: I brought the application (code + current database) on a development machine and on two different servers (one of which currently replaced the site not working) and runs smoothly.
    On my initial machine, making fresh copies of the website there is no way to start it. I tried to do new Application Pool, but without success.
  6. Nicola Achille
    Nicola Achille avatar
    4 posts
    Registered:
    20 Jan 2010
    17 Jun 2011
    Link to this post
    Hi again,
    the sites are not nested, but each of them is hosted under different website, with different app pool.
    In the event viewer i can read this error:

    A process serving application pool 'waterfall' failed to respond to a ping. The process id was '3664'.


    Any idea?
    Best regards,
    Nicola
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Jun 2011
    Link to this post
    Hi Nicola ,

    Since this happens only on a single server it looks like as an infrastructure issue, but not for the project. There must be some log of the machine that will provide why the server is not responding. I am not sure what the problem is.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
7 posts, 0 answered