+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / null reference when adding ContentView herited control

null reference when adding ContentView herited control

2 posts, 0 answered
  1. Kenny South
    Kenny South avatar
    16 posts
    Registered:
    11 Jan 2010
    18 Nov 2010
    Link to this post
    Hi,

    I've got the same error as posted here: (same error, same stacktrace)

    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/bugs-issues/null-reference-when-adding-generic-content.aspx#931431

    i.e. , a null reference exception is thrown when i add a control in edit mode.

    However, in my case the control i try to add is not a generic content control, but a custom control inherited from Contentview ( to provide a list of items for a custom module )

    Further information:

    Sitefinity Version 3.6.1870.2, Framework 2

    This error just appear. There is actually some objects of this type on several pages.
    These controls are working just fine.
    It's just the action of adding a new object on a page which causes the problem.

    Any tips about the cause?
    Is this a known bug solved by the sp2? (i read the corrections list of the sp1, but i did not find the correction list for the sp2)

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 Nov 2010
    Link to this post
    Hi Kenny,

    Try upgrading your project to the latest official release or just get your control and port it in Sitefinity 3.7 SP3 2136 edition and see whether the problem will appear. No one here has managed to replicate the issue locally so far.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered