+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / "Object reference not set to an instance of an object." when adding controls

"Object reference not set to an instance of an object." when adding controls

2 posts, 0 answered
  1. Jason
    Jason avatar
    1 posts
    Registered:
    18 Aug 2011
    26 Aug 2011
    Link to this post
    For some reason whenever I try to drag and drop a control in the "Edit page" mode, the control isn't added. I try to add them with the "add" button but the message "Object reference not set to an instance of an object." appears instead of the control. My application pool is set to work with .NET 2.0 and I changed it to .NET 4.0 to see if that resolved the problem, because as far as I know SiteFinity 3.7 SP4 (which is the version I have installed) can work with a .NET 4.0 environment. I made changes to the web.config to fix some "System.Extensions" duplicates and get SiteFinity to work but still the "Object reference not set to an instance of an object." keeps popping up when I try to add controls. How can I solve this? 

    Thanks.
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    31 Aug 2011
    Link to this post
    Hi Jason,

    Can you please send me the control so I can inspect the problem more closely?(you can open a support ticket and send the control)
    Also can you tell me how do you register the control?
    Have yo tried adding a simple control which doesn`t reference any assemblies that are not by default referenced in Sitefinity?

    All the best,
    Stanislav Velikov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

2 posts, 0 answered