+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Overlay Disabled

Overlay Disabled

4 posts, 0 answered
  1. nitin jain
    nitin jain avatar
    3 posts
    Registered:
    06 Jul 2009
    31 Jul 2009
    Link to this post
    I am using Sitefinity 3.6. I faced a very peculiar problem with overlay mode. Visual Studio has an option to Format Document which formats the HTML so that it is more readable. What this option does is make the contentplaceholder html like this:

     

    <asp:ContentPlaceHolder ID="TopMenu" runat="server">

     

    </asp:ContentPlaceHolder>

     

     

    Now when the master page is opened for editing in Sitefinity in overlay mode the contentplaceholder gets disabled. Now if i change the code to look like this

    <

    asp:ContentPlaceHolder ID="TopMenu" runat="server"></asp:ContentPlaceHolder>

     

     

     

     

     

     

     

     

    the overlay works fine is not disabled. The classic mode has no such problem.

    I am not sure if anyone has faced this, but it really baffled me as to why the master page contentplaceholders were disabled in overlay mode.

    Regards
    Nitin

     

  2. nitin jain
    nitin jain avatar
    3 posts
    Registered:
    06 Jul 2009
    31 Jul 2009
    Link to this post
    This editor sucks.. it has formatted the text of my post in a bad way...
  3. nitin jain
    nitin jain avatar
    3 posts
    Registered:
    06 Jul 2009
    31 Jul 2009
    Link to this post
    this is how it should look:

    I am using Sitefinity 3.6. I faced a very peculiar problem with overlay mode. Visual Studio has an option to Format Document which formats the HTML so that it is more readable. What this option does is make the contentplaceholder html like this:

    <asp:ContentPlaceHolder ID="TopMenu" runat="server">
    </asp:ContentPlaceHolder>
     
    Now when the master page is opened for editing in Sitefinity in overlay mode the contentplaceholder gets disabled. Now if i change the code to look like this

    <asp:ContentPlaceHolder ID="TopMenu" runat="server"></asp:ContentPlaceHolder>

    the overlay works fine is not disabled. The classic mode has no such problem.

    I am not sure if anyone has faced this, but it really baffled me as to why the master page contentplaceholders were disabled in overlay mode.

    Regards
    Nitin

     

  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    31 Jul 2009
    Link to this post
    Hello nitin jain,

    We are aware of this issue with the placeholders. You can also use the following statement:
    <asp:ContentPlaceHolder ID="TopMenu" runat="server" />

    In general, the Overlay mode works with content place holders that do not have white spaces or other controls inside. 

    This is improved in the next page editor. 

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
Register for webinar
4 posts, 0 answered