+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Polls Odd Behavior

Polls Odd Behavior

4 posts, 0 answered
  1. Allen
    Allen avatar
    71 posts
    Registered:
    04 Aug 2007
    08 Jun 2009
    Link to this post
    I have SiteFinity 3.6 and have easily created a poll.  Additionally, I have added a poll box to a page.  The poll displays as expected, but when I (or anyone) tries to vote the poll simply postsback and maintains a "0 votes".  Additionally, the results link simply postsback to the same page.  I am sure there is something very simple I need to set, but cannot figure out what.  Any ideas?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    09 Jun 2009
    Link to this post
    Hello Allen,

    Have you changed any of the control properties as TotalVotersText or ShowTotalVotesPreview or another property. Generally the control works without problems at my end. It require only setting the PollID. You could try creating a test page and adding a new control there to see whether you will reproduce the same behavior. If the problem persists, write back to us. Any additional information will be helpful.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Thomas
    Thomas avatar
    1 posts
    Registered:
    26 Oct 2010
    02 May 2011
    Link to this post
    I inserted a poll on our homepage.  I created a question and 4 answers.  I did not change any of the default settings in the poll.  I then used the drag and drop to put it on the page.

    It appears correctly, but there is no ability to vote.  I can click on an answer, and the dot appears in the circle next to the answer.  But when I click on the vote button, nothing happens.  Absolutely nothing.  No error, no page change, nothing.  It is as if the vote button boesn't work.

    When I click on results, it says no one has voted yet.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 May 2011
    Link to this post
    Hello,

    Please check if there are any client side errors. If you put the PollBox control on a new page do you get the same result? It  is possible that there is something in your current page or master page( template) that breaks the Vote button somehow, so you can check whether the issue persists under another scenario. I also believe that you have set a poll from the control designer.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered