+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Problem with file extensions...

Problem with file extensions...

4 posts, 0 answered
  1. Todd
    Todd avatar
    3 posts
    Registered:
    09 Apr 2008
    03 Jun 2008
    Link to this post
    Hello,

    I am having problems with DWG files. I have been able to upload them, however when I create the link for them to be opened it sends me to a 404 error page. When the link is clicked in it should give the user the option to open or save the file.

    Any suggestions or help would be great. I could zip the files but would rather not have to take that route.

    Thanks,
  2. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    05 Jun 2008
    Link to this post
    Hi Todd,

    Actually, how do you upload your file through the system? Are you using the File Manager or the Images & Documents module? If latter is the case, the problem might hide somewhere in the settings of the module. Either way, we would need some more information about your problem. How do you upload the file, do you have similar problems with other file formats or only for this extension? Sending the Sitefinity.log file, located in the App_Data folder will be of help too.

    Thanks in advance for your cooperation.

    All the best,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Todd
    Todd avatar
    3 posts
    Registered:
    09 Apr 2008
    05 Jun 2008
    Link to this post
    Hi Vassil,

    I have uploaded one file to do a test directly into a folder I created, I did not try the file manager in my test.

    I have uploaded PDF's which open fine and also ZIP files which give the user the option to save or open. As far giving you the app file I deleted my test page after the company I was working with couldn't help me figure this problem out. I am very close to launching the site and would like to get this figured out.

    Thanks,

    Todd
  4. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    10 Jun 2008
    Link to this post
    Hello Todd,

    So it seems that you have problems with DWG files only. If that is the case, the problem might hide somewhere outside of Sitefinity. For example, if you have any http handlers defined in the web.config, they might handle requests for those files and give you the inappropriate message. The problem might hide in IIS if you have added this extension as a mapping. You could check that easily if you create some dummy link in one of your pages, which points to a similar file and see what the result will be.

    Let us know how it goes.

    Regards,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered