+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Problem with RadEditor control

Problem with RadEditor control

5 posts, 0 answered
  1. sundeep
    sundeep avatar
    7 posts
    Registered:
    19 Oct 2010
    20 Oct 2010
    Link to this post
    Hi,
    I am using RadEditor control in my custom control(.ascx). it is working fine, the only issue is when this whole control is added in the new sitefinity module say Products as like news or generic content, the bottom scrollbar is coming in that rad editor. I want to remove the scrollbar. please help me out. But this is working properly in normal page.
    and also bullet listing is not showing.

    i am attached the image.

    Thanks in advance

    Sundeep.K
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    20 Oct 2010
    Link to this post
    Hello sundeep,

    Thank you for using our services.

    The RadEditor is picking up the page's css rules for its content area and this is probably why you are experiencing this issue. Can you please try setting the ContentAreaCssFile property of the RadEditor as bellow:
    <telerik:RadEditor
        ...
        ContentAreaCssFile="~/Sitefinity/Admin/Themes/Default/AjaxControlsSkins/Sitefinity/EditorContentArea.css"
       ...>




    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. sundeep
    sundeep avatar
    7 posts
    Registered:
    19 Oct 2010
    20 Oct 2010
    Link to this post
    Hi,
    I have added the code that u supplied, even its not working..

    here is the code what i did..

    <telerik:RadEditor ID="txtProjectContent" runat="server" CssClass="style_txt"
                                    ContentAreaCssFile="~/Sitefinity/Admin/Themes/Default/AjaxControlsSkins/Sitefinity/EditorContentArea.css">
                                    </telerik:RadEditor>
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    20 Oct 2010
    Link to this post
    Hello sundeep,

    Can you please try clearing the browser cache. Also you can try with the following markup:
    <fieldset class="set">
        <div class="setIn">
            <telerik:RadEditor
                id="txtProjectContent"
                runat="server"
                contentareacssfile="~/Sitefinity/Admin/Themes/Default/AjaxControlsSkins/Sitefinity/EditorContentArea.css"
                toolsfile="~/Sitefinity/Admin/ControlTemplates/EditorToolsFile.xml"
                skin="WebBlue"
                newlinebr="False"
                width="95%"
                ContentFilters="EncodeScripts,FixUlBoldItalic,FixEnclosingP,IECleanAnchors,MozEmStrong,ConvertFontToSpan,ConvertToXhtml,IndentHTMLContent">
                     
                </telerik:RadEditor>
        </div>
    </fieldset>


    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. sundeep
    sundeep avatar
    7 posts
    Registered:
    19 Oct 2010
    21 Oct 2010
    Link to this post
    Hi Radoslav Georgiev,

    Now the Radeditor its doing well the way i wanted .

    Thanks for your timely help...
Register for webinar
5 posts, 0 answered