+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Problem with Shared Content / Permissions?

Problem with Shared Content / Permissions?

3 posts, 0 answered
  1. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    31 Jan 2008
    Link to this post
    Hi,

    I just upgraded a client from 3.1SP1 to 3.1SP2 and all their shared content isn't visible to users now.  This page http://www.waldorfgarden.org/admissions/openhouseschedule.aspx for example, has shared content on it.  If I edit the page, I see the shared content, if I preview the page, I see the shared content, but if I look at without ?cmspagemode=preview or =edit, there is no content.  I checked the permissions of shared content and the pages and everything, and can't see anything I'm missing.

    Any ideas?

    Thanks

    Ben
  2. Ben Alexandra
    Ben Alexandra avatar
    215 posts
    Registered:
    15 Sep 2012
    31 Jan 2008
    Link to this post
    PS This isn't an issue of the page not being published.  All this content was there before the upgrade, I've tried publishing, rolling back, etc.  It's happening on lots of pages, not just that one.

    Thanks
  3. Sonya
    Sonya avatar
    231 posts
    Registered:
    24 Sep 2012
    31 Jan 2008
    Link to this post
    Hello Ben Alexandra,

    This is a known issue. Please run the following script in your database:

    update 
        sf_CmsTextContent 
    set 
        Culture = 127 
    where 
        Culture = 1033  
        and not exists(select ID from sf_CmsTextContent t2 where t2.ID = sf_CmsTextContent.ID and t2.Culture = 127) 
     

    Please let us know how it goes. If this does not help, please send us your database.



    Greetings,
    Sonya
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
3 posts, 0 answered