+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Publishing/Canceling Changes does not work anymore

Publishing/Canceling Changes does not work anymore

7 posts, 1 answered
  1. gabs002
    gabs002 avatar
    64 posts
    Registered:
    17 Dec 2009
    28 Jan 2010
    Link to this post
    Hallo there,

    I got a big Problem!
    I wanted to edit a page. I tried to delete a content, but it doesn't work. The site reloaded, but nothing else happened. And if I click 'Publish' or 'Cancel' there happens nothing either! It's strange, because it concerns only one certain page. What can be the problem?

    Hope you can help me soon!

    Thank you, Gabriele
  2. gabs002
    gabs002 avatar
    64 posts
    Registered:
    17 Dec 2009
    28 Jan 2010
    Link to this post
    Hi again,

    my assumption is, that my control is too big? Is this possible? I split the control (2 tables). If I insert the first table, which has not more then 7 rows, I have no problem. But as soon as I insert my second one, which has more than 100 rows, I can't edit anything else anymore.

    Hope you can help me!

    Thank you, Gabriele
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jan 2010
    Link to this post
    Hi Gabriele Muerth,

    You have a control on this page that causes this behavior, js error or something in the theme. You can start excluding the control one by one to see from where the actual problem comes from. Then you can debug the code of the control to see whether there is something wrong with its logic.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  4. gabs002
    gabs002 avatar
    64 posts
    Registered:
    17 Dec 2009
    28 Jan 2010
    Link to this post
    Hi sitefinity team,

    and thank you for your prompt answer.
    I created a table with html-code. Inside this table I got only one ASP-ImageButton, which was the problem. Now I'm wondering why this should be a problem? I usually always mix html and asp, and I didn't ever have a problem. Do you have an explanation?

    Thank you for your excellent support!
    Regards, Gabriele
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jan 2010
    Link to this post
    Hello Gabriele Muerth,

    If you paste the control here using FormatCode block option of the RadEditor we could try to figure out what is going wrong.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. gabs002
    gabs002 avatar
    64 posts
    Registered:
    17 Dec 2009
    28 Jan 2010
    Link to this post
    This is the code

    [...]  
     <tr> 
       <td> 
                  
       </td> 
       <td align="center">  
            <asp:ImageButton runat="server" ImageUrl="~/Images/Registrieren.png" PostBackUrl="../../Registrierung.aspx" style="padding-top:5px;padding-bottom:0px" /> 
       </td> 
    </tr> 
    [...] 


    If I comment out the ImageButton I have no problem anymore. Maybe the style-attribute is the problem?

    Thank You, Gabriele
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jan 2010
    Link to this post
    Hi Gabriele Muerth,

    Take a look at this KB article - Sitefinity page freezes in Edit mode

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
Register for webinar
7 posts, 1 answered