+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RadEditor IE8 & Firefox problem

RadEditor IE8 & Firefox problem

2 posts, 0 answered
  1. Foodsleuth
    Foodsleuth avatar
    46 posts
    Registered:
    21 May 2008
    26 Jul 2009
    Link to this post
    Hi,
    We are having a problem with content entered into a (generic content control, radeditor) when using Firefox and IE8.  Firefox is adding a <br> tag to the end of the content and IE8 puts <p> tags around the content.  Either or both of those tags are altering the look of our page.
    Additionally we have a custom module with several entry fields.  When we save the record, Firefox puts a <br> tag in the empty fields and this is creating a problem too.
    Is there a work around for this?  These problems don't occur with IE7

    Thanks
    Barb
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    27 Jul 2009
    Link to this post
    Hello Foodsleuth,

    Please try to remove the "FixEnclosingP" filter from the ContentFilters of the RadEditor.
    You will need to use external templates. Just open the template you need, find the RadEditor and edit the ContentFilters section. More information about RadEditor's ContentFilters is available here.

    Hope this helps.

    All the best,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
2 posts, 0 answered