+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RadRotator not rotating

RadRotator not rotating

5 posts, 0 answered
  1. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    11 Oct 2010
    Link to this post
    I have placed a basic Radrotator inside a user control so that I could upload it to a master page for banner rotation.

    I copied the code directly from the telarik website with no modifications other than to change the directories where the files are stored in the control and XML doc.

    The rotator will load the first image from the XML document just fine but will not rotate after that.  it just stays on the same image.

    I have even replaced the html image tag with an asp:image tage as suggested here...

    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/developing-with-sitefinity/image-gallery-slide-show.aspx

    but I still have the same issue.

    There are no errors of any kind.`

    This is a 3.7 community site running on ASP.NET 4.0 platform

    Could really use some help
  2. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    11 Oct 2010
    Link to this post
    Small update here.

    I took the example code from the  telerik demo site and inserted it into a control and used it on a Sitefinity 3.7 Standard .NET 3.5 site and it works just fine.

    Could there be something wrong with the 3.7 NET 4.0 community edition?
  3. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    11 Oct 2010
    Link to this post
    Ok it evidently has something to do with the item height and width but fo rthe life of me I cant figure out what?

    I have the example working on my community site but as soon as I try to match the height and width of my graphics it breaks...

    Why?
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    11 Oct 2010
    Link to this post
    Hello bleutiger,

    You can check if the suggestions in this forum thread apply to you: Problem with Xml As Data Sources for the RadRotator.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    11 Oct 2010
    Link to this post
    OK wow...

    Found the issue but man is it confusing.  This control has to be configured just right.

    Evidently the div on my master page where my content place holder is was smaller that the Rotator control so it would kill the rotation of the control .  I am not exactly sure why it would do that but oh well.  Got it figured out.

    Hope this helps someone else.
Register for webinar
5 posts, 0 answered