+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RadTabStrip not working in user control

RadTabStrip not working in user control

7 posts, 0 answered
  1. jbull
    jbull avatar
    17 posts
    Registered:
    26 Jun 2012
    11 May 2008
    Link to this post
    I've created a user control that uses a RadTabStrip and RadMultiPage. It works fine  if I put it on a generic page using one of my sitefinity master pages and just test it out of the root directory rather than putting it on a page within sitefinity.  However, if I utilize the same masterpage placing the usercontrol on a sitefinity generated page, nothing happens when I click any of the tabs on the RadTabStrip.  It's as if they aren't linked up to the RadMultiPage anymore.
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    12 May 2008
    Link to this post
    Hello jbull,

    We have already answered you in your support ticket entitled "RadTabStrip problem".
    We are closing this thread now.

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Dave
    Dave avatar
    76 posts
    Registered:
    10 Mar 2008
    13 May 2008
    Link to this post
    I'm curious what the fix was, because I'm having similar problems with RadToolTipManager (working on a test page but not in a Sitefinity control).
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    13 May 2008
    Link to this post
    Hello Dave,

    I am pasting the reply to Jeff's support ticket. Please note that RadToolTipManager is a different control and we need more information to assist you.

    Unfortunately, we cannot reproduce any problem. The RadMultiPage and the RadTabStrip controls are natively integrated. All you need to do is set the MultiPageID property of the tabstrip to the ID of the respective multipage instance. If the controls are not inside the same naming container, you should use the value of the UniqueID property of your multipage.

    For your convenience I have attached a simple example that demonstrates how to use RadTabStrip together with RadMultiPage. If this does not help, please send us your User Control to test it locally.

    Best wishes,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Dave
    Dave avatar
    76 posts
    Registered:
    10 Mar 2008
    13 May 2008
    Link to this post
    Thanks Pepi.
  6. Vinoth
    Vinoth avatar
    2 posts
    Registered:
    31 Aug 2012
    20 Jan 2011
    Link to this post
    Hi Pepi,

    I'm using RadTabStrip control to my project,
    Her, i've two kinds of tab
    1. Compose
    2. Poll
    both pages i have button control, suppose i choose Compose and do the action and go to poll again i add poll. its work normally.
    but whenever i choose first Poll after done action i can't open the compose. 

    help me in this part 

    Thanks in Advance 
    Vinoth.X
  7. Jitka
    Jitka avatar
    1 posts
    Registered:
    29 Nov 2010
    24 Mar 2011
    Link to this post
    Thanks Pepi, that helped. Jitka Darbujanova
Register for webinar
7 posts, 0 answered