+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Redirect to the default URL

Redirect to the default URL

6 posts, 0 answered
  1. Matt
    Matt avatar
    16 posts
    Registered:
    29 May 2008
    05 Jan 2009
    Link to this post
    I'm having an issue with the "Redirect to the default URL" feature on pages. 

    The first time a page with a default redirect is loaded by a user, the page is loaded from the url given, without redirect.  If the page is refreshed, the user is then redirected to the appropriate location.

    This is important for us because the first URL is in a different directory.  The page references a java applet which loads other (path-relative) resources.  As a result, the first time the user visits the page, the java applet does not load properly.  The second time the applet loads fine.

    The only relevant information I believe we may be doing any differently is that we're adding an extension to the UrlHelper (Telerik.Cms.Web.UrlHelper.Extensions.Add) and redirecting from the non-standard extension (.cfm) to the standard extension (.aspx).  (The new site is a conversion from Cold Fusion in which our client wants to keep the old urls.)

    (I'm on Sitefinity 3.2)

    Matthew DeKrey
    Tribal DDB


  2. Parvan
    Parvan avatar
    151 posts
    Registered:
    24 Sep 2012
    09 Jan 2009
    Link to this post
    Hello Matt,

    Thank you for contacting us.

    In version 3.2 Hotfix 1616 there was a problem with page redirection and custom page extensions.
    Which is your exact version? You may check it by following the steps in that KB Article - http://www.sitefinity.com/support/knowledge-base/kb-article/b1154K-bbac-b1154T-cgb.aspx

    This information will help us to test your problem in the exact environment.

    Best wishes,
    Parvan
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Matt
    Matt avatar
    16 posts
    Registered:
    29 May 2008
    09 Jan 2009
    Link to this post
    Seems that I already have 1616; my version is:

    Sitefinity 3.2.1616.2:0
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    12 Jan 2009
    Link to this post
    Hi Matt,

    We had some problems exactly with page extensions different than the default ones. Could you please let me know if you are adding your additional extension exactly as it is showed in the Kb Article Error when Using Page Extension Different from the Default One?

    You may also try with this approach.

    Sincerely yours,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Matt
    Matt avatar
    16 posts
    Registered:
    29 May 2008
    12 Jan 2009
    Link to this post
    Yes, I am using the page extensions exactly as you have specified in that article; thanks for the link, though.

    Matthew DeKrey
    Tribal DDB
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Jan 2009
    Link to this post
    Hi Matt,

    Could you please open a support ticket and provide us with a link to your web site? We will examine the configuration and will see the status codes returned. Them we will try to come up with suggestion.

    All the best,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
6 posts, 0 answered