+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / response.redirect doesn't work when there's another control on the page

response.redirect doesn't work when there's another control on the page

7 posts, 1 answered
  1. Sharlyne
    Sharlyne avatar
    30 posts
    Registered:
    14 Aug 2008
    30 Jan 2011
    Link to this post
    I have created a page that has a submit button. Upon click of that button i have a response.redirect. Through my testing I noticed that if I load a template that has a control (login control in my case) with a submit button in the header, my response.redirect does not work. It just "refreshes" the page. If I choose a different template (without the login control), then my redirect works properly with no issue.

    What causes this? Is there a way around this?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Jan 2011
    Link to this post
    Hello ASA,

    I cannot replicate the issue locally. Can you send some more details about where and how the controls are configured?

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Sharlyne
    Sharlyne avatar
    30 posts
    Registered:
    14 Aug 2008
    31 Jan 2011
    Link to this post
    In my template in one of the placeholders I put a login control. In another placeholder in the body of the template I put my new control. How can I show you how the controls are configured?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Feb 2011
    Link to this post
    Hello ASA,

    Could you check whether the click event is fired when both the controls are on the pages? Form what you are saying the click event doesn't seem to be triggered.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Sharlyne
    Sharlyne avatar
    30 posts
    Registered:
    14 Aug 2008
    04 Feb 2011
    Link to this post
    You are right. The event is not being triggered at all. What could be causing this?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    07 Feb 2011
    Link to this post
    Hi ASA,

    Check whether you are setting PostBackUrl somewhere. Try using HyperLink if possible.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  7. Sharlyne
    Sharlyne avatar
    30 posts
    Registered:
    14 Aug 2008
    09 Feb 2011
    Link to this post
    Thanks Ivan! That was it.
Register for webinar
7 posts, 1 answered