+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / RSS feed and other areas of sitefinity not working

RSS feed and other areas of sitefinity not working

7 posts, 1 answered
  1. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    05 Oct 2010
    Link to this post
    Hi,

    The RSS Feeds area of sitefinity, along with the newsletter and wiki modules are no longer working. The RSS Feed on the website still worked until the other day when the unassigned blog post was published, causing the RSS to not work.

    But when trying to access the RSS Feeds area in sitefinity to change the blog settings, it gives an error and does not let me in. I get the same error when trying to access Wiki and Newsletter.

    I think it might be something to do with when I upgraded to SP4, in the upgrade instructions it said something about deleting a file so that one of the modules would work... but when trying to delete that file it wouldn't let me.

    Can someone please let me know if there is anything I can do to get these areas of sitefinity working again.

    Thanks,
    Paul
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    06 Oct 2010
    Link to this post
    Hi Paul,

    1. What is the stack trace of this  error?

    2. Try deleting your rss feeds from the database

    • sf_RssChannels
    • sf_RssChannelsSettings
    • sf_RssFeeds

    and if the backend allow you to access this section you will be able to recreate the old links.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    06 Oct 2010
    Link to this post
    Hi Ivan,

    I'm pretty sure the reason the rss feed isnt working is because of the blog post created on the 4th of october under an unassigned blogger. So hopefully once it is off the top 10 the rss will work again, although it seems to have broken the index when i try and reindex the blogs... So may need to delete the post from the database to fix all these problems.

    Unsure of the stack trace, as it seems to be giving a custom error page, and is just saying "Website is Offline" - that seems to be the error page this is displayed all the time now.

    Thanks,
    Paul
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    06 Oct 2010
    Link to this post
    Hi Paul,

    You could check the log file inside App_Data/sitefinity.log or temporarily disable the custom errors you have turned on.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    06 Oct 2010
    Link to this post
    Hi Ivan,

    Heres the stack trace from clicking RSS Feeds within Sitefinity

    Compiler Error Message: CS1502: The best overloaded method match for 'System.Web.UI.Control.ResolveUrl(string)' has some invalid arguments

    Source Error:

    Line 20:                         <h3 runat="Server" id="feedName"><asp:Literal runat="server" Text='<%# Eval("Name") %>'></asp:Literal></h3>
    Line 21:                         <p runat="Server" id="feedDescription"><asp:Literal runat="server" Text='<%# Eval("Description") %>'></asp:Literal></p>
    Line 22:                         <p runat="Server" id="P2"><asp:HyperLink runat="server" Text='<%# Eval("Url") %>' NavigateUrl='<%# Page.ResolveUrl(Eval("Url")) %>' rel="external"></asp:HyperLink></p>
    Line 23:                     </div>
    Line 24:                     <div class="values">

    Source File: d:\vhosts\magnetism.co.nz\httpdocs\Sitefinity\Admin\ControlTemplates\RssFeeds\ViewFeeds.ascx Line: 22

    Thanks,
    Paul
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    06 Oct 2010
    Link to this post
    Hello Paul,

    The values passed to Page.ResolveUrl(Eval("Url")) cannot be resolved. This is the link that you have used to set Feed URL when you have created the feed. You should recreate your feeds as suggested above.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  7. Paul N
    Paul N avatar
    55 posts
    Registered:
    24 Apr 2010
    07 Oct 2010
    Link to this post
    Hi Ivan,

    Thanks for the help, I fixed the rss feeds area in sitefinity by updating the ViewFeeds.ascx file, and changing...
    NavigateUrl='<%# Page.ResolveUrl(Eval("Url")) %>'
    to be...
    NavigateUrl='http://www.magnetism.co.nz/sitefinity/admin/CmsAdmin/Services.aspx?service=RSS+Feeds'
    not sure if thats right, but that worked. I was then able to recreate the feed.

    Thanks,
    Paul
Register for webinar
7 posts, 1 answered