+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / rss feed link bug

rss feed link bug

2 posts, 0 answered
  1. Mary-Joyce Schimann
    Mary-Joyce Schimann avatar
    4 posts
    Registered:
    03 Mar 2009
    03 Feb 2010
    Link to this post
    I created a rss feed for news, the ashx source is like this:
    <item>
          <title>news title 2</title>
    <description>&lt;p&gt;222 Type your content here...&lt;/p&gt; &lt;p&gt;........&lt;/p&gt; &lt;p&gt;&lt;/p&gt;</description>
    <link>http://localhost/10-02-02/news_title_2.aspx</link>
          <author>admin</author>
    <comments>http://localhost/10-02-02/news_title_2.aspx</comments>
    <guid isPermaLink="false">a45d5381-8213-4af4-9073-c1b20bda1849</guid>
    <pubDate>Tue, 02 Feb 2010 21:39:21 GMT</pubDate>
    </item>
    <item>
    <title>news title 1</title>
          <description>&lt;p&gt;Type your content here...&lt;/p&gt; &lt;p&gt;........&lt;/p&gt; &lt;p&gt;&lt;/p&gt;</description>
    <link>http://localhost/10-02-02/news_title_1.aspx</link>
    <author>admin</author>
          <comments>http://localhost/10-02-02/news_title_1.aspx</comments>
    <guid isPermaLink="false">aa5ba4bf-7832-49c2-bd09-01e6a712bad8</guid>
    <pubDate>Tue, 02 Feb 2010 21:37:52 GMT</pubDate>
    </item>

    But when I went to these links
    http://localhost/10-02-02/news_title_1.aspx
    or
    http://localhost/10-02-02/news_title_2.aspx
    a server error occured :

    The resource cannot be found.

    Description: HTTP 404.
    then I added '/news/' in the link as follow:
    http://localhost/news/10-02-02/news_title_2.aspx
    I could see the news detail page correctly.

    What should I do to fix this bug?
    Thanks,
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 Feb 2010
    Link to this post
    Hello Mary-Joyce Schimann,

    Thank you for using our services.

    When you have created your RSS service did you set the page which you have created to store your news. When the url is generated you must point to a page where you have a News View control, this is most certainly the reason why you were getting the resource not found error. See attached image for sample configuration of the News RSS. Note that the page which you set as your article page should contain the News View control.

    Best wishes,
    Radoslav Georgiev
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
2 posts, 0 answered