Try Now
More in this section

Forums / Bugs & Issues / Search indexing not working for SSL required site

Search indexing not working for SSL required site

2 posts, 0 answered
  1. Greg
    Greg avatar
    2 posts
    20 Feb 2008
    22 Feb 2008
    Link to this post
    In IIS 6.0, we have checked the box that says "Require secure channel (SSL)", since we want all of our clients to log in and view our site securely.

    However, I can't get Search Indexes to work.  Each time I click "Start indexing", the Sitefinity interface hangs. It looks like the spider is trying to grab URLs that start with http:// instead of https://  

    Here is an example from sitefinity.log:
    - L0 -------------------------------------------------------------------------------

    Exception Type: Telerik.Search.Engine.IndexExcepton

    Message: An error has occurred while indexing the following document:  "http://example.com:443/abc/newtestpage.aspx". Please see inner exception for more details.


    Stack Trace:

    - L1 -------------------------------------------------------------------------------

    Exception Type: System.Net.WebException

    Message: The operation has timed out

    Source: System

    Stack Trace:
       at System.Net.HttpWebRequest.GetResponse()
       at Telerik.Search.Engine.Crawler.SpiderURLs(String Provider, String[] urls, Boolean appendToIndex)

    How can I fix this?  Note:  ALL traffic will require SSL, so I still want to enforce this option at the web server level.

  2. Georgi
    Georgi avatar
    3583 posts
    10 Oct 2016
    25 Feb 2008
    Link to this post
    Hello Greg,

    We must confirm this is a bug and it will be fixed in the final release of v3.2.
    We have updated your Telerik points for reporting this.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered