+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Session state not working on production server

Session state not working on production server

3 posts, 0 answered
  1. Brett Winklesky
    Brett Winklesky avatar
    2 posts
    Registered:
    08 Dec 2009
    14 Jun 2010
    Link to this post
    Hi everybody-

    I'm not sure where to turn on this issue, but I have a custom control that is trying to read a session variable on a page within Sitefinity.  The server is running session state InProc on the server (win 2008).  Unfortunately, I'm not able to retrieve the session ID's from any page inside sitefinity. 

    The control works on my local machine, so it's a configuration setting of some kind.  Has anybody experienced this before?   
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    15 Jun 2010
    Link to this post
    Hello Brett Winklesky,

    Thank you for using our services.

    By default we do not do anything with session state withing Sitefinity. This means that session state should be enabled by default (unless configured otherwise) on your production server. You can try setting up session state from your web.config explicitly:
    <system.web>
        <!-- Sets the allowed upload file size -->
        <httpRuntime maxRequestLength="51200" />
        <sessionState mode="InProc" cookieless="false" timeout="20"></sessionState>
        <pages enableSessionState="true">

    You can find more information about <sessionState> configuration section here: ASP.NET Session State.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Brett Winklesky
    Brett Winklesky avatar
    2 posts
    Registered:
    08 Dec 2009
    15 Jun 2010
    Link to this post
    Hi Radoslav-

    Thanks for the feedback! I actually figured it out.  It had to do with using the Advanced URL rewriting in Sitefinity.  Apparently the session state doesn't work when using extension-less URL rewriting.  So I modified my custom rules to read in the extension and seems to work fine.  Cheers!

    BW


      
Register for webinar
3 posts, 0 answered