+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity 3.0 doesn't support the strict html doctype

Sitefinity 3.0 doesn't support the strict html doctype

7 posts, 0 answered
  1. Ines
    Ines avatar
    9 posts
    Registered:
    22 Jun 2007
    03 Jul 2007
    Link to this post

    Hi telerik,

    I’ve been evaluating your CMS for about 2 weeks. It is very good application, by the way. I noticed that Sitefinity 3.0 does not support the strict html doctype but only transitional. I mean, I type <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd"> in my master page and get the following error, when trying to validate the page:

    Error Line 9 column 15: there is no attribute "name".

    <form name="aspnetForm" method="post" action="/TestProject/TestPage.aspx" id="asp

    Could you help me to fix the problem because the strict html doctype is a main requirement for this project? Also, our timeframe is very tight.

    Thanks a lot in advance for your help!

    Ines

  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    03 Jul 2007
    Link to this post
    Hi Ines,

    Unfortunately this problem is not related to Sitefinity but to ASP.NET. We will try to work around it in the next release. If we figure out something, we will write back immediately.

    We are really sorry for the inconvenience.

    Best wishes,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Ines
    Ines avatar
    9 posts
    Registered:
    22 Jun 2007
    03 Jul 2007
    Link to this post

    Hi Pepi,

    To be honest, I didn’t expect such an answer. I’ve checked today the online examples of the telerik RAD Controls. There is an XHTML 1.1 compliancy mark and of course I was curious to check if they’d managed with the error reported by me earlier today. There is no “there is no attribute "name".” error. You can check this link: http://www.telerik.com/demos/aspnet/TabStrip/Examples/Functionality/FirstLook/DefaultCS.aspx

    So, my next questions are:

    Is it so difficult to ask your workmates from the RAD Controls department for the solution? Obviously, they managed to fix it.

    You mentioned that probably you might’ve fixed this problem for the next release. Do you think that this answer will motivate me to buy your product? How do you think I could plan my project without clear release dates? If your next release is behind a schedule again, this wouldn’t be acceptable for my customer .

    Best wishes,

    Ines

  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    04 Jul 2007
    Link to this post
    Hello Ines,

    We will provide a new Service Pack these days and the fix of this problem will be included in it.

    I am sorry I couldn't explain the reason for the problem and its solution previously.
    The problem is that if you try to create an XHTML document using ASP.NET, you will probably fail since the code generated by the ASP.NET engine is not XHTML. A lot of errors are automatically created when the page is being rendered in the web browser.

    <form name="aspnetForm" method="post" action="/TestWeb/home.aspx" id="aspnetForm">

    The form attribute name needs to be removed in order to make the code XHTML compliant. A possible solution is to implement a custom form inheriting HtmlForm and remove the name attribute from its Attribute collection for Strict doctype.

    There are a lot of articles for valid XHTML within .NET. You can have a look at this one http://www.liquid-internet.co.uk/content/dynamic/pages/series1article1.aspx for example.

    Again sorry for the incomplete answer.

    All the best,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Ines
    Ines avatar
    9 posts
    Registered:
    22 Jun 2007
    05 Jul 2007
    Link to this post

    Hi Pepi,

    Thank you very much for your comprehensive answer. I’m very glad to hear that you manage to find solution for this problem. I’m eagerly waiting for the next hotfix. Can you tell me a tentative date for its release?

    Thanks once again.

    Ines

  6. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    05 Jul 2007
    Link to this post
    Hi Ines,

    SP2 will be available next week but we found a solution for the problem. You should just set mode attribute in xhtmlConformance element to Strict.

    <system.web>
        <xhtmlConformance mode="Strict" />
    </ system.web>

    Hope this helps.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Ines
    Ines avatar
    9 posts
    Registered:
    22 Jun 2007
    06 Jul 2007
    Link to this post

    Hi Pepi,

    Thanks a lot for your answer and for the provided solution. It works perfect.

    Best wishes,
    Ines

Register for webinar
7 posts, 0 answered