+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity project Manage not loading site through Cassini

Sitefinity project Manage not loading site through Cassini

2 posts, 0 answered
  1. Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    11 Mar 2011
    Link to this post

    Hi Ivan,

    I have informed you about this earlier, I have created new Project in Sitefinity4.0, and added our own dlls in bin folder, after that Sitefinity project manager not loading Project.

    You told me that project manager use Cassini web server. Please find below highlighted text ( our conversation on Cassini). Can you please help me out how to set reference in Cassini webserver or web config to remove assembly binding error.
    i have gone thrugh the link you provided, but i am not able to understand how i should proceed.

     

    Hi Rashmi,

    The Cassini runs in 32 bit mode. You can find the source code for  dev servers at http://cassinidev.codeplex.com if you need to compile under 64 mode.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!




    From: Rashmi
    Date: 3/1/2011 5:47:18 AM

    hi Ivan

    Thanks for reply. 
    I was getting same assembly binding error in IIS also, but when I set enable 32 bit Application = true in Application pool the error gone.
    can we set Enable 32 bit Applications true in Cassini web server. if yes, how I can do that?

    Thanks
    Rashmi




    From: Telerik Admin
    Date: 2/25/2011 8:54:12 AM

    Hello Rashmi,

    The ProjectManager of Sitefinity uses Cassini which opens in a random port. Our ProjectManager server does not use IIS. The error you are getting is because you have added some custom handler in the project and it is not referenced now.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!




    From: Rashmi
    Date: 2/25/2011 5:45:53 AM

    hi  Ivan


    I have followed all the steps to Install Sitefinity 4.0 on IIS 7, for Virtual directory i have set Port = 81, when i try to load project through IIS, it get loaded successfully and url is "http://localhost:81/",  but if i try to load same project through project manager the port number get changed and i am getting error for assembly binding , please find attachment.
    Please let me why port no get changed and to resolve it.
    <_o3a_p>


    Regards
    Rashmi



     

     

    Thanks & Regards,

    Rashmi Panchal

     

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    16 Mar 2011
    Link to this post
    Hi Rashmi,

    Please make sure that you have registered the handler properly in your web.config

    http://msdn.microsoft.com/en-us/library/46c5ddfy.aspx in both the sections for IIS classic and integrated mode. Also please make sure that you have a reference to the dll that holds the custom handler

    http://msdn.microsoft.com/en-us/library/wkze6zky%28v=vs.80%29.aspx

    Regards,
    Ivan Dimitrov
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
2 posts, 0 answered