+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sometimes not all the images will load

Sometimes not all the images will load

20 posts, 0 answered
  1. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    15 Dec 2009
    Link to this post
    On our sitefinity site, sometimes when a page will load, not all the images will load. It can be an image that is in the content or an image that is part of the template used by the page. If the page is refreshed, all the images will then be visible.

    Are there any known issues with Sitefinity pages not loading all images sometimes?

    I've attached a screenshot as an example. The "2" image in the tabs along the right is not displaying, but the source address when I look at the properties of the missing image is correct.

  2. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    15 Dec 2009
    Link to this post
    Trying again to attach the screenshot.
  3. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Dec 2009
    Link to this post
    Hello Elizabeth,

    Thank you for posting your question.

    We are not aware of such problem yet. Which version are you using? 

    At the moment, I can only suggest you to inspect all get requests with Fiddler or another tool, and to check the server response code when you see broken image. You can also take a look in the Sitefinity.log file, and send relevant errors to this issue to us.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  4. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    28 Dec 2009
    Link to this post
    This happens to all our Sitefinity 3.7 sites.  Its random but very annoying.  I installed the Elmah error catcher thing to track errors, and I get this error:

    System.NullReferenceException: Object reference not set to an instance of an object.

    Generated: Mon, 28 Dec 2009 15:01:46 GMT

    System.NullReferenceException: Object reference not set to an instance of an object.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at System.Collections.Generic.Dictionary`2.set_Item(TKey key, TValue value)
       at Telerik.Web.UrlRewriterService.Cache(String url, IUrlRewriteData info)
       at Telerik.Cms.Engine.ContentUrlRewriterService.GetUrlData(CmsHttpRequest request)
       at Telerik.Cms.Engine.ContentUrlRewriterService.GetContentItem(CmsHttpRequest request)
       at Telerik.Cms.Engine.ContentHttpHandler.GetContentItem(HttpContext context)
       at Telerik.Cms.Web.CmsHttpHandlerBase.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    		

  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Dec 2009
    Link to this post
    Hi Eric,

    A temporary solution is to disable the caching in the Images and Documents module. You can still use Browser cache though. 

    We are currently investigating the issue, and will follow up to this thread once know more about it.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 Jan 2010
    Link to this post
    Hello,

    We are still working on resolving the issue. Hopefully we will be done before the upcoming service pack, and will include the fix with it. Meanwhile, can you spot any certain pattern on reproducing the problem? Perhaps if you have several requests to the same item?

    Thank you for your patience. 

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    12 Jan 2010
    Link to this post
    We have turned off caching in the libraries. I haven't noticed any pattern as to when this is happening. On one of our sites (it's not 'live' yet but can be seen at brownrisd DOT hillel DOT org), I'm not seeing the problem but another user is. It got worse for him after he refreshed. His browser info:

    Safari 4.0.4  

    Firefox 3.6 

    Google Chrome 4.0.249.49 (35163) beta 

    I've also attached screenshots that he sent me.

  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    13 Jan 2010
    Link to this post
    Hi Elizabeth,

    We are still chasing the cause of the error. We haven't been able to reproduce this yet. Perhaps there is a way for you to send us your project? We can set it up locally and try to reproduce the problem there. Otherwise, we will update the thread with some more information once we have it (it's in my ToDo).

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    13 Jan 2010
    Link to this post
    I'll fill out a support ticket with a link to a download location.
  10. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    04 Feb 2010
    Link to this post
    Any updates?
  11. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 Feb 2010
    Link to this post
    Hello Eric,

    Thank you for getting back to us.

    We are currently investigating the issues when using caching with the Images and Documents module. We have the issue logged and will try to come up with a fix for this in the upcoming Service Pack release.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  12. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    19 Feb 2010
    Link to this post
    I was just talking to another developer who has had the same problem.  He's been waiting on a fix since version 3.5.  That seems a little ridiculous that this has been an issue for so long, and the only solution is to wait to an upcoming release.

    I just started a new site today using 3.7 sp2, got my images in the library, template created, and a splash page up... and the logo which is stored in the image and document module with the caching turned off, randomly does not appear. 

    I am going to bring this to my managers attention and make him aware of the lack of timely solutions and recommend we abandon Sitefinity altogether and use Umbraco.

    Thanks for the lack of help.
  13. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    22 Feb 2010
    Link to this post
    Hi Eric,

    The problem persists in 3.7 SP2 and I believe that we will be able to fix it for the forthcoming SP. I am sorry for the inconvenience caused.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  14. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    23 Feb 2010
    Link to this post
    Highly doubtful.  I just installed the Elmah error handler on a 3.2 site, same image library issues.  So basically we've needed this fix since the creation of the Image and Documents module.

    So how many versions and service packs have been issued since 3.2 with no fix?

    We get these errors dozens of times and multiple different sites and multiple different servers.  It's really an unacceptable "INCONVENIENCE".  What are we supposed to tell our clients?
  15. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    23 Feb 2010
    Link to this post
    Hello Eric,

    The concept in 3.2 is rather different to the concept taken in 3.5 and later versions. 

    Could you please let me know if you are holding a Sitefinity license, since I see that you have downloaded Sitefinity Community edition only, which is not supported? It will also help if you can provide us with any certain steps, environment and possibly stack trace of the errors you are getting. 

    Thank you in advance. 

    Greetings,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  16. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    23 Feb 2010
    Link to this post
    All our licenses have been purchased under jason@innismaggiore.com

     
  17. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    23 Feb 2010
    Link to this post

    System.NullReferenceException: Object reference not set to an instance of an object.

    Generated: Sun, 21 Feb 2010 12:08:46 GMT

    System.NullReferenceException: Object reference not set to an instance of an object.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at System.Collections.Generic.Dictionary`2.set_Item(TKey key, TValue value)
       at Telerik.Web.UrlRewriterService.Cache(String url, IUrlRewriteData info)
       at Telerik.Cms.Engine.ContentUrlRewriterService.GetUrlData(CmsHttpRequest request)
       at Telerik.Cms.Engine.ContentUrlRewriterService.GetContentItem(CmsHttpRequest request)
       at Telerik.Cms.Engine.ContentHttpHandler.GetContentItem(HttpContext context)
       at Telerik.Cms.Web.CmsHttpHandlerBase.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    		

    Server Variables

    Name Value
    ALL_HTTP HTTP_CONNECTION:Keep-Alive HTTP_ACCEPT:*/* HTTP_ACCEPT_ENCODING:gzip, deflate HTTP_ACCEPT_LANGUAGE:en-us HTTP_COOKIE:ASP.NET_SessionId=2zp2ur553rak5k45gjp1ebii HTTP_HOST:www.danscoengineering.com HTTP_REFERER:http://www.danscoengineering.com/?gclid=CLuq9d2yg6ACFSJ25QodaTgLlQ HTTP_USER_AGENT:Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)
    ALL_RAW Connection: Keep-Alive Accept: */* Accept-Encoding: gzip, deflate Accept-Language: en-us Cookie: ASP.NET_SessionId=2zp2ur553rak5k45gjp1ebii Host: www.danscoengineering.com Referer: http://www.danscoengineering.com/?gclid=CLuq9d2yg6ACFSJ25QodaTgLlQ User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)
    APPL_MD_PATH /LM/W3SVC/493821799/Root
    APPL_PHYSICAL_PATH E:\Inetpub\wwwroot\DEVELOPMENT\Dansco\
    AUTH_TYPE  
    AUTH_USER  
    AUTH_PASSWORD  
    LOGON_USER  
    REMOTE_USER  
    CERT_COOKIE  
    CERT_FLAGS  
    CERT_ISSUER  
    CERT_KEYSIZE  
    CERT_SECRETKEYSIZE  
    CERT_SERIALNUMBER  
    CERT_SERVER_ISSUER  
    CERT_SERVER_SUBJECT  
    CERT_SUBJECT  
    CONTENT_LENGTH 0
    CONTENT_TYPE  
    GATEWAY_INTERFACE CGI/1.1
    HTTPS off
    HTTPS_KEYSIZE  
    HTTPS_SECRETKEYSIZE  
    HTTPS_SERVER_ISSUER  
    HTTPS_SERVER_SUBJECT  
    INSTANCE_ID 493821799
    INSTANCE_META_PATH /LM/W3SVC/493821799
    LOCAL_ADDR 192.168.30.42
    PATH_INFO /Libraries/Banners/Dansco_Banner1.sflb.ashx
    PATH_TRANSLATED E:\Inetpub\wwwroot\DEVELOPMENT\Dansco\Libraries\Banners\Dansco_Banner1.sflb.ashx
    QUERY_STRING  
    REMOTE_ADDR 142.163.92.153
    REMOTE_HOST 142.163.92.153
    REMOTE_PORT 61631
    REQUEST_METHOD GET
    SCRIPT_NAME /Libraries/Banners/Dansco_Banner1.sflb.ashx
    SERVER_NAME www.danscoengineering.com
    SERVER_PORT 80
    SERVER_PORT_SECURE 0
    SERVER_PROTOCOL HTTP/1.1
    SERVER_SOFTWARE Microsoft-IIS/6.0
    URL /Libraries/Banners/Dansco_Banner1.sflb.ashx
    HTTP_CONNECTION Keep-Alive
    HTTP_ACCEPT */*
    HTTP_ACCEPT_ENCODING gzip, deflate
    HTTP_ACCEPT_LANGUAGE en-us
    HTTP_COOKIE ASP.NET_SessionId=2zp2ur553rak5k45gjp1ebii
    HTTP_HOST www.danscoengineering.com
    HTTP_REFERER http://www.danscoengineering.com/?gclid=CLuq9d2yg6ACFSJ25QodaTgLlQ
    HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)

    Powered by ELMAH, version 1.1.11517.2009 (debug; RC; net-3.5). Copyright (c) 2004-9, Atif Aziz. All rights reserved. Licensed under Apache License, Version 2.0.

  18. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    25 Feb 2010
    Link to this post
    Hi Eric,

    Thank you for providing the stack trace and the error information. 

    It's coming from an application which is not 3.2 as said in your initial message, but is 3.7 - 3.7.1990. , at least http://www.danscoengineering.com/ is built with 3.7 and the error is from it. 

    We have scheduled regression testing and improving the code related to this error (since it's the same as in the previous messages) and hopefully we could release a fix in the SP3, coming in the mid of March. We will first have to find a way to reproduce this locally.

    Kind regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  19. Eric
    Eric avatar
    19 posts
    Registered:
    06 Nov 2007
    25 Feb 2010
    Link to this post
    Heres the 3.2

    System.NullReferenceException: Object reference not set to an instance of an object.

    Generated: Mon, 22 Feb 2010 20:16:21 GMT

    System.NullReferenceException: Object reference not set to an instance of an object.
       at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       at System.Collections.Generic.Dictionary`2.set_Item(TKey key, TValue value)
       at Telerik.Web.UrlRewriterService.Cache(String url, IUrlRewriteData info)
       at Telerik.Cms.Engine.ContentUrlRewriterService.GetContentItem(String path)
       at ContentHttpHandlerFixture.ContentHttpHandlerFix.ProcessRequest(HttpContext context) in e:\Sitefinity3.2\WebSites\Cortland32\App_Code\CustomContentHandler.cs:line 40
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    		

    Server Variables

    Name Value
    ALL_HTTP HTTP_CONNECTION:Keep-Alive HTTP_ACCEPT:*/* HTTP_ACCEPT_ENCODING:gzip, deflate HTTP_ACCEPT_LANGUAGE:en-US HTTP_COOKIE:__utma=145134630.444651833.1265206288.1266433504.1266802585.15; __utmz=145134630.1266802585.15.15.utmcsr=aol|utmccn=(organic)|utmcmd=organic|utmctr=cortlande%20banks%20homepage; ASP.NET_SessionId=52to42vc0mhb1yivjca1iwbn HTTP_HOST:www.cortland-banks.com HTTP_REFERER:http://www.cortland-banks.com/ HTTP_USER_AGENT:Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF)
    ALL_RAW Connection: Keep-Alive Accept: */* Accept-Encoding: gzip, deflate Accept-Language: en-US Cookie: __utma=145134630.444651833.1265206288.1266433504.1266802585.15; __utmz=145134630.1266802585.15.15.utmcsr=aol|utmccn=(organic)|utmcmd=organic|utmctr=cortlande%20banks%20homepage; ASP.NET_SessionId=52to42vc0mhb1yivjca1iwbn Host: www.cortland-banks.com Referer: http://www.cortland-banks.com/ User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF)
    APPL_MD_PATH /LM/W3SVC/1306783766/Root
    APPL_PHYSICAL_PATH E:\Sitefinity3.2\WebSites\Cortland32\
    AUTH_TYPE  
    AUTH_USER  
    AUTH_PASSWORD  
    LOGON_USER  
    REMOTE_USER  
    CERT_COOKIE  
    CERT_FLAGS  
    CERT_ISSUER  
    CERT_KEYSIZE  
    CERT_SECRETKEYSIZE  
    CERT_SERIALNUMBER  
    CERT_SERVER_ISSUER  
    CERT_SERVER_SUBJECT  
    CERT_SUBJECT  
    CONTENT_LENGTH 0
    CONTENT_TYPE  
    GATEWAY_INTERFACE CGI/1.1
    HTTPS off
    HTTPS_KEYSIZE  
    HTTPS_SECRETKEYSIZE  
    HTTPS_SERVER_ISSUER  
    HTTPS_SERVER_SUBJECT  
    INSTANCE_ID 1306783766
    INSTANCE_META_PATH /LM/W3SVC/1306783766
    LOCAL_ADDR 192.168.30.42
    PATH_INFO /Libraries/Promo+Images/TOPHMPGImageRotationSKIPAPA.sflb
    PATH_TRANSLATED E:\Sitefinity3.2\WebSites\Cortland32\Libraries\Promo+Images\TOPHMPGImageRotationSKIPAPA.sflb
    QUERY_STRING  
    REMOTE_ADDR 204.210.217.150
    REMOTE_HOST 204.210.217.150
    REMOTE_PORT 62948
    REQUEST_METHOD GET
    SCRIPT_NAME /Libraries/Promo+Images/TOPHMPGImageRotationSKIPAPA.sflb
    SERVER_NAME www.cortland-banks.com
    SERVER_PORT 80
    SERVER_PORT_SECURE 0
    SERVER_PROTOCOL HTTP/1.1
    SERVER_SOFTWARE Microsoft-IIS/6.0
    URL /Libraries/Promo+Images/TOPHMPGImageRotationSKIPAPA.sflb
    HTTP_CONNECTION Keep-Alive
    HTTP_ACCEPT */*
    HTTP_ACCEPT_ENCODING gzip, deflate
    HTTP_ACCEPT_LANGUAGE en-US
    HTTP_COOKIE __utma=145134630.444651833.1265206288.1266433504.1266802585.15; __utmz=145134630.1266802585.15.15.utmcsr=aol|utmccn=(organic)|utmcmd=organic|utmctr=cortlande%20banks%20homepage; ASP.NET_SessionId=52to42vc0mhb1yivjca1iwbn
    HTTP_HOST www.cortland-banks.com
    HTTP_REFERER http://www.cortland-banks.com/
    HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF)

    Powered by ELMAH, version 1.1.11517.2009 (debug; RC; net-2.0). Copyright (c) 2004-9, Atif Aziz. All rights reserved. Licensed under Apache License, Version 2.0.

  20. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Feb 2010
    Link to this post
    Hello Eric,

    As far as I see it you use custom handler that seems to be the reason for this error and your problems.

    ContentHttpHandlerFixture.ContentHttpHandlerFix.ProcessRequest(HttpContext context)
    in e:\Sitefinity3.2\WebSites\Cortland32\App_Code\CustomContentHandler.cs:line 40



    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
20 posts, 0 answered