+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Static google map as content

Static google map as content

4 posts, 0 answered
  1. Ivan
    Ivan avatar
    51 posts
    Registered:
    22 Aug 2007
    05 May 2010
    Link to this post
    Hi All,

    I am having a problem inserting a static google map reference into a generic content block.  It seems like certain characters in the html string are breaking the rad editor. Here is the string I am trying to insert via HTML mode:

    <img src="http://maps.google.com/maps/api/staticmap?center=1370 Marin Street,94124&zoom=15&size=200x200&maptype=roadmap&markers=color:red|1370 Marin Street,94124
    &sensor=false&key=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"/>

    I have also attached a screenshot of the error message thrown by the editor:

    Error while executing filter XHTML - TypeError: 'getAttribute(...).length' is null or not an object

    Any help would be appreciated.  Thanks.
    -Ivan
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 May 2010
    Link to this post
    Hello Ivan,

    I tried the same snippet at my end and there is not problem to insert the image through GenericContent control which wraps RadEditor or through any of the modules. It seems that you have and you are  editing some non well formed / non XHTML compliant content which misleads the RadEditor.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Ivan
    Ivan avatar
    51 posts
    Registered:
    22 Aug 2007
    05 May 2010
    Link to this post
    Hi Ivan,

    Yes, I can paste the link as indicated and get the map to display if I follow these steps:
    1. edit a Generic Content module
    2. change to HTML mode
    3. paste snippet
    3. click "I'm done" button

    However, if I need to edit the link that is when I generate the error. Here are the steps to create the error in my scenario:
    1. edit a Generic Content module containing static map link
    2. error msg displays

    I don't think I have non well formed HTML as you may have indicated. I created a Generic Content module just with the static google map and got the error.

    Is there a web.config setting or generic content module attribute that I need to set to prevent this error from occurring?  I am running the Community Edition at a hosting provider (seekdotnet) if you think that might matter.

    Any additional advice would be appreciated.  Thanks.
    -Ivan
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 May 2010
    Link to this post
    Hello Ivan,

    You could try to remove ConvertToXhtml from the GenericContentDesigner template ( please take a  look at How to map a template) .

    If the problem persist after removing the filter, please tell us the exact version of Sitefinity you use, send us the content you use and screencast that represents the problem, so we could check our code.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
4 posts, 0 answered