+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sub page not visible in navigation

Sub page not visible in navigation

4 posts, 0 answered
  1. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    07 Nov 2007
    Link to this post
    I have a top level page with a usercontrol on it. Then I have a sub page not visible in navigation. That sublevel page seems to be linked to its parent page. If I change the usercontrol on the sub page and click save the usercontrol is changed on both pages and the top level page is selected. I am not sure if I explained that very well. Not a big deal currently, but there may be an issue there.

    Sincerely,

    Ben
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    07 Nov 2007
    Link to this post
    Hi Ben,

    Could you please explain in details the steps to reproduce this issue? If I understand correctly, you have two pages:
    1. Parent page with a UserControl on it
    2. Child page (subpage of Parent page) that is not a part of site navigation i.e. Show in navigation is set to No

    It is not quite clear if both parent and child pages contain the same UserControl or the testing scenario is different. Are you changing the source code of the control or its properties in edit mode of the page? In the first case, the change should be reflected on all pages containing the control and in the second scenario the change should be just in the corresponding page.

    Thanks for your cooperation in advance.

    Kind regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. bnye
    bnye avatar
    332 posts
    Registered:
    22 Sep 2005
    08 Nov 2007
    Link to this post
    Pepi -

    I apologize for the delay. Your steps 1 and 2 are correct. And then:

    3. I placed a different usercontrol on the child page.
    4. Save
    5. Edit Child Page. At this point It seems that I am editing the Parent Page. The Parent Page User control appears on this page and after saving the Parent Page is selected even though I was editing the Child Page.

    I hope I explained that well.

    Sincerely,

    Ben
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    09 Nov 2007
    Link to this post
    Hello Ben,

    Thanks for the comprehensive explanation.

    Unfortunately, we can't reproduce the described behavior. It seems to work according to expectations. So send us both your project and database so we can figure out what is wrong. Also, please point out the pages causing the problem.

    Thanks in advance.

    Kind regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered