+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The resource cannot be found. Server Error in '/' Application.

The resource cannot be found. Server Error in '/' Application.

20 posts, 0 answered
  1. jbull
    jbull avatar
    17 posts
    Registered:
    26 Jun 2012
    02 Apr 2008
    Link to this post
    I am constantly getting the following error The resource cannot be found. Server Error in '/' Application. when I try to edit pages. We are on 3.2 SP1.  Any help would be appreciated
  2. jbull
    jbull avatar
    17 posts
    Registered:
    26 Jun 2012
    02 Apr 2008
    Link to this post
    More info on this error.  It seems to only happen on page nested within page groups. Interestingly, I get the error continually when i am trying to add or edit pages, but if i navigate in the sitemap to the the first nested page in the page group, then i can view the other nested pages within that group fine until i make another edit.
  3. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    08 Apr 2008
    Link to this post
    Hello jbull,

    Thanks a lot for providing further details about the error.
    This looks like a very serious bug. We'll definitely need more time to reproduce this and to pinpoint the reason for its occurrence. We'll get back to you as soon as we have some results.

    Greetings,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. iOleksiy
    iOleksiy avatar
    6 posts
    Registered:
    07 Apr 2008
    11 Apr 2008
    Link to this post
    I have the same for WinXP/2003/Vista (have tried on all of them). Have downloaded the latest 3.2SP1 version "Standart" full installator. And for the 4th day already I am testing my nerves.
  5. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Apr 2008
    Link to this post
    Hello Oleksiy,

    Although you get the same error, the problem with your site might be caused by something different.
    Please make sure you have added ISAPI mappings for .template extension on the server. You can have a look at the attached screenshots demonstrating the requirements for the web site configuration.
    For more details about adding application mappings, see User Manual, chapter Configuring IIS or section Troubleshooting.

    Let us know if this does not fix the problem and describe the steps to reproduce it.

    Kind regards,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Apr 2008
    Link to this post
    Sorry Oleksiy, I didn't notice you were talking about Vista. This is how to add the .template extension in the application web.config, section <system.webServer>.

    <system.webServer>  
    <handlers>  
       …  
    <add name="Template Handler Factory"   
    path="*.template" verb="*" 
    modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" 
    resourceType="Unspecified"/>  
    </handlers>  
    </system.webServer>  
     


    Sincerely yours,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Apr 2008
    Link to this post
    Hi Jeff,

    We think we found out why you are getting the 404 error. A bug in our Http module (v3.2 SP1) does not allow you to have a first-level page and a template with the same name; when you access such pages, the 404 error is thrown.

    This is certainly going to be fixed in the next release. The temporary solution is to change the name of the templates.

    Let us know if the above is not exactly what you observe.

    Best wishes,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. jbull
    jbull avatar
    17 posts
    Registered:
    26 Jun 2012
    11 Apr 2008
    Link to this post
    Changing the name externally will break all the pages that require it. Is there a SQL statement that I can run that will update all pages with a particular template name?  That way, i can change the template names and then run the script to match them up in the database. Please advise asap.

    Thanks,
    Jeff
  9. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Apr 2008
    Link to this post

    Sorry Jeff, maybe I didn't quite explain what needs to be done. You don't need to externally change the names of the .master files, located in your project App_Master folder, so your pages won't break.

    I was talking about renaming the page templates generated by Sitefinity. What you need to do is:
    1. Go to the Pages > Templates tab.
    2. Select a template with a name corresponding to the first-level page name.
    3. Go to the Properties tab.
    4. Type a new name in the Template name field.
    5. Click Save changes.

    The pages using this particular template are updated automatically, you don't need to go to edit page mode and select the page template from the dropdown again.

    Hope all runs smoothly now. Let us know if you need any further assistance.
     
    All the best,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  10. iOleksiy
    iOleksiy avatar
    6 posts
    Registered:
    07 Apr 2008
    11 Apr 2008
    Link to this post
    Hello Rebecca,

      Here is a screenshot: Screenshot
      Have take a Virtual Machine. Installed Vista Ultimate with SP1 trial. Installed MS SQL 2005 Express with SP2 for Vista. Configured IIS as described in UserManual.pdf. Installed your full installation pack with the latest updates. Have run IE7 under admin, because ProjectManager says "can't create virtual directory". Created new project with company template. Added ".template" handler to web.config of new project.
      Started sitefinity URL - works. But if I browse the website pages or trying to edit some page - get the same error as on the screenshot.

      Notice: I have tried it under MSWindows 2008/2003/XP/Vista test system - on every system there is the same error... Already a bit frustrating, cause it goes for 4 days yet (((

    Best regards,
      Oleksiy.
  11. T
    T avatar
    5 posts
    Registered:
    04 Dec 2007
    12 Apr 2008
    Link to this post
    I'm not sure if this is at all related to the problems being described here.

    I have noticed myself that templates having a name in Sitefinity containing one or more uppercased letters will prevent the template from being displayed. It will just give you the 404 error.
    This will also happen to pages based on this template.

    Regards,
    Tore
  12. iOleksiy
    iOleksiy avatar
    6 posts
    Registered:
    07 Apr 2008
    12 Apr 2008
    Link to this post
    Hi, T.

      Do you think that it is possible if in system with such brand, a lot of years of experience and expensive license could be such problem as letters case??? It can't afford such situation...

    Best regards,
      Oleksiy.
  13. T
    T avatar
    5 posts
    Registered:
    04 Dec 2007
    13 Apr 2008
    Link to this post
    Hi Oleksiy,

    You are right, sorta. I forgot that I am using Oracle as database, and there have been some trouble in doing so. The problem I mentioned could be Oracle specific.

    Regards,
    Tore
  14. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Apr 2008
    Link to this post
    Hi T,

    Most probably the request is not handled correctly, because IIS is looking for a physical path when trying to serve the page with its template. The truth is that we store this information in the database, so the page doesn't exist in the file system.

    When mapping .template in IIS 7, as in IIS 5.x and 6.x, you have to tell the server not to look for a physical file.

    Here's the procedure for IIS 7:
    1) double-click on the handler mapping (.template) in the <handlers> feature.
    2) uncheck the checkbox to set the handler to 'unspecified' as shown in the attached image.


    You shouldn't allow IIS to look for physical path, because all pages are serving dynamically from the database.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  15. T
    T avatar
    5 posts
    Registered:
    04 Dec 2007
    29 Apr 2008
    Link to this post
    Hi again.

    Sorry for the delay in my response.

    I've been playing around in the Sitefinity Admin.

    I'm running it on the built-in webserver of Visual Studio 2008.
    (no IIS involved)

    We use Oracle database.

    In my case Sitefinity does not like it when a template's name has capital letters in it.

    If I for example choose to upload a template in Sitefinity, and give it a name with an uppercase letter, it will fail to display with a 404 not found error.
    Then if I change the template name in Sitefinity (the filename can have uppercase letters), it will work.

    Also if I have any templates with uppercase letters in it, and try to create a new page, I will get a 404 not found message in the page creation process where a template should be selected.

    - Tore
  16. T
    T avatar
    5 posts
    Registered:
    04 Dec 2007
    29 Apr 2008
    Link to this post
    Hi.

    As long as my templates all use lowercase letters they work fine.

    I recently wrote that by having a template with one or more uppercase letters in it's name, I was not able to create pages.

    This is not correct, the reason for not being able to create pages is because I did so using Page Names with one or more uppercased letters.

     - Tore
  17. iOleksiy
    iOleksiy avatar
    6 posts
    Registered:
    07 Apr 2008
    29 Apr 2008
    Link to this post
    Hi, T.
      As I have asked the support team about such problem - they said that this is a bug of current Sitefinity release, and on next update it will be fixed.
      Also, it is due to u have selected case-sensative in properties of DB. Support says select "case-insensative" and it will work...
      Bad thing but bug is bug(((
    Best regards,
      Oleksiy.
  18. T
    T avatar
    5 posts
    Registered:
    04 Dec 2007
    29 Apr 2008
    Link to this post
    Thank you for your prompt answer.

     - Tore
  19. Stephen Bosco
    Stephen Bosco avatar
    2 posts
    Registered:
    10 Nov 2009
    11 Nov 2009
    Link to this post
    Good morning,

    I am a new user and have downloaded the trial version.  I have been following a few posts and have been tweaking the Internet Manager to gain access to a created template.  However; I am receiving a new error message ...

     

    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /Rubicon Tax/Sitefinity/Default.aspx


    Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082



    I am running Windows Server 2003 trying to connect with SQL Server 2005.

    Any thooughts?  Thanks ~ Stephen
  20. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    11 Nov 2009
    Link to this post
    Hi Stephen Bosco,

    Thank you for your interest in our CMS.

    I suspect that the reason for the 404 error is the space in the application name. Can you please try to create a new virtual directory, and point it to the same application? Make sure it doesn't contain any spaces. You can also try to create a new project without a space in the name. 

    Let me know about the results.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
20 posts, 0 answered