+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Timeout expired

Timeout expired

3 posts, 0 answered
  1. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    17 Dec 2008
    Link to this post
    Guys, sometimes in teh mornigs when I turn teh PC on and try to start Sitefinity I get the below error. It happens when I press teh Edit button for one of the projects from teh list of current projects.

    Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.Data.SqlClient.SqlException: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [SqlException (0x80131904): Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.]
       Nolics.ORMapper.DataProviders.SQLDataProvider.Open() +121
       Telerik.DataAccess.NolicsHelper.SetConnection(String connectionName, String providerName) +999
       Telerik.Cms.Data.DefaultProvider.Initialize(String name, NameValueCollection config) +231
       Telerik.ManagerBase`1.InstantiateProvider(ProviderSettings providerSettings, Type providerType) +663
       Telerik.ManagerBase`1.InstantiateProvider(ProviderSettings providerSettings) +102
       Telerik.ManagerBase`1.SetProvider(String providerName) +201
       Telerik.ManagerBase`1..ctor(String providerName) +86
       Telerik.ManagerBase`1..ctor() +11
       Telerik.Cms.CmsWorkflowService..ctor() +23
       Telerik.Cms.CmsWorkflowService..cctor() +20
    
    [TypeInitializationException: The type initializer for 'Telerik.Cms.CmsWorkflowService' threw an exception.]
       Telerik.Cms.CmsWorkflowService.Initialize() +0
       Telerik.Cms.CmsManager.OnInitialized() +5
       Telerik.ManagerBase`1.Initialize() +507
       Telerik.ManagerBase`1..ctor(String providerName) +18
       Telerik.ManagerBase`1..ctor() +11
       Telerik.Cms.CmsManager..ctor() +5
       Telerik.Cms.Web.UrlHelper..cctor() +521
    
    [TypeInitializationException: The type initializer for 'Telerik.Cms.Web.UrlHelper' threw an exception.]
       Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context) +101
       System.Web.HttpApplication.InitModulesCommon() +66
       System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1006
       System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +259
       System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +114
       System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +350

    Have you come accross it at all?

    Thanks

    Andrei
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Dec 2008
    Link to this post
    Hello Andrei,

    Thank you for using our services.
    Please take a look at the following link at TipsStation where this problems is described. It is a server side issue.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    17 Dec 2008
    Link to this post
    Hi Ivan, thanks for the answer. It is working now. I went to the web.config file of teh given site and changed the Timeout setting to zero. Then I tried again, got the error about the Timeout being zero. Changed it back to what it was before and then tried again and it is working now. It happened twice in a couple of weeks. It is a wired error but that is my trick to fix it for now. Thanks for the reply.

    Andrei
Register for webinar
3 posts, 0 answered