+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Uploading Files , error : Collection is Read-Only

Uploading Files , error : Collection is Read-Only

12 posts, 0 answered
  1. Sutrisno Yao
    Sutrisno Yao avatar
    5 posts
    Registered:
    20 Aug 2009
    20 Aug 2009
    Link to this post
    Hello guys, I'm new here, I'm having a problem when I upload files using sitefinity's file manager, I get this error message :

    Collection is read-only.

    Description:An unhandled exception occurred during the execution of the current webrequest. Please review the stack trace for more information about the error andwhere it originated in the code.

    Exception Details:System.NotSupportedException: Collection is read-only.

    Please do suggest me , what should I check? I have just set all the files and folders to have the write permission. Thank you in advance : )

    regards,

    Sutrisno Yao
    JuraganWebHosting.com CIO
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    21 Aug 2009
    Link to this post
    Hello Sutrisno Yao,

    Can you send us the stack trace. Please provide us with some steps so that we will try to reproduce the issue locally.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Sutrisno Yao
    Sutrisno Yao avatar
    5 posts
    Registered:
    20 Aug 2009
    21 Aug 2009
    Link to this post
    Hello, Thank you for replying me, here is the stack trace : do you need how to check the error and access to the sitefinity admin? basically I just go to the file manager > choose file > when I press the upload button it shows collection is read-only error. Thanks.

    Stack Trace:

    [NotSupportedException: Collection is read-only.]   System.Collections.Specialized.NameValueCollection.Set(String name, String value) +5259386   System.Web.HttpHeaderCollection.SynchronizeHeader(String name, String value) +32   System.Web.HttpRequest.SynchronizeHeader(String name, String value) +44   System.Web.Hosting.IIS7WorkerRequest.GetHeaderChanges(HttpContext ctx, Boolean forRequest) +941   System.Web.Hosting.IIS7WorkerRequest.SynchronizeVariables(HttpContext context) +52   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +477
    
                

    regards,

    Sutrisno Yao
    JuraganWebHosting.com CIO
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    26 Aug 2009
    Link to this post
    Hello Sutrisno Yao,

    Thank you for the provided details.

    Are you using IIS7? Are you working in Medium trust? Could you please check the following forum thread - http://www.telerik.com/community/forums/aspnet-ajax/upload/iis7-instructions-incorrect.aspx

    It describes the same problem. There are some suggestions there which you might try.
    Please let us know about the results and the progress with the issue.

    Thank you for your cooperation in advance.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  5. Ivan
    Ivan avatar
    51 posts
    Registered:
    22 Aug 2007
    05 May 2010
    Link to this post
    Hi All,

    I am having a similar issue.  I using Sitefinity in a shared environment at a hosting provider (seekdotnet).  After I initially created photo galleries I was able to add and edit images.  However after a certain period, whenever I tried to add or edit an asset to the a previously created gallery I was getting the "Collection is Read-Only" error. I am not sure what caused this loss of functionality. Below is the full stack trace.

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Collection is read-only. 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.NotSupportedException: Collection is read-only.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

    Stack Trace: 

    [NotSupportedException: Collection is read-only.]
       System.Collections.Specialized.NameValueCollection.Set(String name, String value) +5259386
       System.Web.HttpHeaderCollection.SynchronizeHeader(String name, String value) +32
       System.Web.HttpRequest.SynchronizeHeader(String name, String value) +44
       System.Web.Hosting.IIS7WorkerRequest.GetHeaderChanges(HttpContext ctx, Boolean forRequest) +941
       System.Web.Hosting.IIS7WorkerRequest.SynchronizeVariables(HttpContext context) +52
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +477
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:2.0.50727.3603; ASP.NET Version:2.0.50727.4049 

    Any help would be greatly appreciated.  Thanks.
    -Ivan
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 May 2010
    Link to this post
    Hi Ivan,

    Could you please paste the relevant error messages from the Sitefinity.log file? The log file is located in the App_Data directory - I guess it would help us determine the real issue. 
    Thanks in advance. 

    Kind regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. Sutrisno Yao
    Sutrisno Yao avatar
    5 posts
    Registered:
    20 Aug 2009
    05 May 2010
    Link to this post
    Hi Ivan ,

    I would like to share how I fixed this issue, simply, the problem usually caused by the application pool type set to integrated on IIS 7, I changed to classic and it's fixed.  Could you please check it? The other cause is usually caused by the component on the isapi filters on IIS, you need to remove the component which you don't use. 

    regards,

    Sutrisno Yao
    JuraganWebHosting.com CIO
  8. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 May 2010
    Link to this post
    Hello Sutrisno Yao,

    Thank you very much for elaborating the problem. We will surely check this, although there shouldn't be such problem in classic mode. 
    It's good to know though that everything fine on your side now. Let me know if you face any other problem!

    All the best,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  9. Sutrisno Yao
    Sutrisno Yao avatar
    5 posts
    Registered:
    20 Aug 2009
    05 May 2010
    Link to this post
    Hello,

    Yes you are welcome, maybe you could suggest us , any server level settings which need to be set in order to make sitefinity working properly? 

    regards,

    Sutrisno Yao
    JuraganWebHosting.com CIO
  10. Ivan
    Ivan avatar
    51 posts
    Registered:
    22 Aug 2007
    05 May 2010
    Link to this post
    Thanks for the quick response Georgi and Sutrisno!

    My hosting provider resolved the issue for me but I am going to investigate further to understand what they did to fix the issue.

    Regards.
    -Ivan
  11. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    05 May 2010
    Link to this post
    Hi Sutrisno

    I though you have fixed the problem on your side. Could you please elaborate on what is not working properly, so we can provide you with a feedback on the server settings?
     
    Regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  12. Sutrisno Yao
    Sutrisno Yao avatar
    5 posts
    Registered:
    20 Aug 2009
    06 May 2010
    Link to this post
    Hello Georgi,

    Yes I have fixed the problem by changing the application pool. I mean that are there any requirements which need to be set before we install sitefinity? To avoid this problem happening again. Thanks.

    regards,

    Sutrisno Yao
    JuraganWebHosting.com CIO
Register for webinar
12 posts, 0 answered