+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Video Thumbnail issue when moving to WS2008 and IIS7

Video Thumbnail issue when moving to WS2008 and IIS7

8 posts, 0 answered
  1. Bryan
    Bryan avatar
    14 posts
    Registered:
    20 Aug 2008
    23 Jun 2010
    Link to this post
    Hello,
    We had a client site running for about a year on a windows server 2003,IIS 6 machine with no problems, but since we have migrated the site to a windows server 2008, IIS7 machine the video upload have stop generating thumbnails. I have seen a similar unresolved post and I have checked the items you have listed:

    1. It is running in Full .Net Trust Level.
    2. There is no thumbnail record in the database.

    It seems obvious its a configuration error, but I am not familiar with the differences between WS 2003/ IIS6 and WS 2008/ IIS7.

    Any thoughts?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    23 Jun 2010
    Link to this post
    Hello Bryan,

    There is a difference between IIS 6 and IIS 7 related the the handler registration. You could find more description at MSDN. More information about the differences between IIS6 and IIS 7 can be find here

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Bryan
    Bryan avatar
    14 posts
    Registered:
    20 Aug 2008
    28 Jun 2010
    Link to this post
    Hello Ivan,
    Thanks for the links. I decided to do a fresh install of Sitefinity 3.6 SP2 on the new server hoping that the installation in the native environment (WS2008/IIS7) would have Sitefinity configure itself correctly. After the installation was complete I went into the admin dashboard and tried to upload a video. Same problem, still no thumbnail. Is this a know issue? Does Sitefinity work in this type of server setup?

    As I had mentioned before, we normally work in a WS2003/IIS6 environment and the normal Sitefinity installation has worked great for each site we have setup. Is there additional instructions I should be following to get 3.6 SP2 to work in WS2008/IIS7?

    Thanks.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jun 2010
    Link to this post
    Hello Bryan,

    Ok after spending some time debugging I figured out what the problem was. We use RadUpload for uploading items and from UploadedFile.Content we get the mime type. Under Server 2008 the Content is passed as application/octet-stream instead of video/x-ms-wmv. The UploadedFile is wrapper of ASP.NET HttpPostedFile and we are not changing anything. Even if you use ASP.NET FileUpload you will see that the content under server 2008 is application/octet-stream instead of video/x-ms-wmv.
    Since this comes from ASP.NET there is nothing that we can do.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Bryan
    Bryan avatar
    14 posts
    Registered:
    20 Aug 2008
    28 Jun 2010
    Link to this post
    Hello Ivan,

    Are you saying then that Sitefinity 3.6 does not work completely in a WS2008 environment? Are there any plans to address this issues in a service patch? Does Sitefinity 3.7/4.0 address this issue?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jun 2010
    Link to this post
    Hi Bryan,

    As you can see from my reply the issue is not related to Sitefinity itself. The content property that returns HttpPostedFile is not correct for Windows Server 2008, but the value is correct for other OS. You can gather more information at MSDN - HttpPostedFile.ContentType Property.
    Since this property returns MIME content type of a file and we use it directly from the ASP.NET Framework there is nothing that we can do in Sitefinity 3.x editions.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Bryan
    Bryan avatar
    14 posts
    Registered:
    20 Aug 2008
    28 Jun 2010
    Link to this post
    Hello Ivan,

    Yes I did not mean it was a Sitefinity issue, but if that is how Windows Server will handle the content type moving forward I was wondering if the 3.x versions would be patched to handle this exception. Would upgrading to Sitefinity 4.0 handle the issue with the conetent type in Windows Server 2008?
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Jun 2010
    Link to this post
    Hello Bryan,

    We will add this as limitation in 3.x editions and we will avoid it in Sitefinity 4.0.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
8 posts, 0 answered