+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / yellow screen when trying to insert an image with paging

yellow screen when trying to insert an image with paging

8 posts, 0 answered
  1. Jason
    Jason avatar
    12 posts
    Registered:
    18 Sep 2006
    14 Oct 2008
    Link to this post
    When we try to insert an existing image on a page from a gallery with more than 50 items, we get

    A required control was not found in the template for "Telerik.Cms.Web.UI.Pager+PagerContainer". The control must be assignable form type "System.Web.UI.WebControls.Repeater" and must have ID "PageRepeaterHyperLink".

    Any help would be appreciated

    Thank you
    Jason

  2. Jason
    Jason avatar
    12 posts
    Registered:
    18 Sep 2006
    14 Oct 2008
    Link to this post
    # Open a web browser and go to http://localhost/Sitefinity/Login.aspx
    # Click Pages along the top navigation bar
    # Click the Press page along the left hand navigation bar
    # Click Edit this page
    # Mouse over one of the content areas and click the Edit link
    # In the subwindow that opens click the Insert an Image icon
    # Click Select from already uploaded images
    # Click Content Pages (which has 144 images)
    # the error comes up  
    (if you click the library with 40 images, it works)
  3. Jason
    Jason avatar
    12 posts
    Registered:
    18 Sep 2006
  4. bemara57
    bemara57 avatar
    135 posts
    Registered:
    27 Mar 2008
    24 Jan 2010
    Link to this post
    Happens with me, but with the "Event view" in version 3.7 SP2. I worked around it by going to Advanced -> Pager -> RenderPagerAsLink and set it to true.
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Jan 2010
    Link to this post
    Hello bemara57,

    We have similar bug in 3.7 SP1 which is fixed in 3.7 SP2. The settings you are referring - RenderCurrentPageAsLink does not have anything to do with the file selector. RenderCurrentPageAsLink makes the pager that is used for event items as hyperlink.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Dec 2010
    Link to this post
    Hi there

    <meta name="Generator" content="Sitefinity 3.7.2096.3" />

    A required control was not found in the template for "". The control must be assignable form type "System.Web.UI.WebControls.Repeater" and must have ID "PageRepeaterLinkButton".

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    EventView
    When unchecking Divide the list on pages if there are too many items

    Display items per page.

     it worked.

    Markus
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Dec 2010
    Link to this post
    Hello Markus,

    "A required control was not found in the template for "". The control must be assignable form type "System.Web.UI.WebControls.Repeater" and must have ID "PageRepeaterLinkButton"."

    This issue was fixed on 9.27.2010 which is after we released Sitefinity 3.7 SP4. The problem is related to the template. If you want you can get a custom build from us through our support system.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 Dec 2010
    Link to this post
    Dear Ivan

    No problem, it worked that way and I guess I can wait for SP5 :-)

    I just wanted to report it because it was mentioned that it was fixed in SP 2

    Have a good weekend
    Markus
Register for webinar
8 posts, 0 answered