+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / z-index RadMenu vs. AjaxControlToolkit

z-index RadMenu vs. AjaxControlToolkit

5 posts, 1 answered
  1. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    19 Mar 2010
    Link to this post
    I am developing a site that uses the Site Menu control in Sitefinity for my main site navigation and then also have a menu of external links that is using the AjaxControlToolkit hover menu extender.
    Please see:
    http://template.education.wisc.edu/About/AdvisoryCommittee.aspx
    The SOE and UW menus are using the hover menu extender.
    This was working fine with version 3.0.30512.0 of the AjaxControlToolkit, but if I upgrade to 3.0.30930.0 my hover menu extender menu always shows up behind the "Site Menu" no matter how high of a number is set on z-index through CSS. I've had my hover menu set to 10000 with no luck... but 9999999 didn't work either.
    From what I can tell, the Site Menu(RadMenu) is z-index: 7000... am I correct?
    The hover menu items display over other items on the page except the Site Menu.

    Since we are developing a template to be used for many sites, we'd like the option of using pieces from the AjaxControlToolkit and would like to keep up with new versions as they come out.

    I would appreciate any suggestions regarding compatibilities with the AjaxControlToolkit and Sitefinity.

    Thanks in advance!

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    19 Mar 2010
    Link to this post
    Hi Scott Rozman,

    Thank you for using our services.

    You are correct that the default z-index of the SiteMenu control is 7000. I have inspected your page and all seemed fine. The z-index applied to the other menu was 10000 and it appeared on top of the SiteMenu, you can refer to attached image. Are the controls on the page upgraded to the latest version? If yes probably the issue you were experiencing before was related to browser cache preventing you to see the changed style rules.

    All the best,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    19 Mar 2010
    Link to this post
    Radoslav, thanks for looking at my site. I provided the link, so you would see how I am using the 2 elements together, but you looked at it with older AjaxControlToolkit version.
    I've just swapped out to the latest version.
    Please view again.
    http://template.education.wisc.edu/About/AdvisoryCommittee.aspx

    I would like to try and figure out if there are any known compatibility issues that I should be avoiding... if this is something that should be reported as an issue to Telerik... or something that should be reported to the AjaxControlToolkit team.

    Also, FYI, I am using the Sitefinity 3.7 SP3, asp.net 3.5 version (although I was seeing this with 3.7 SP1 as well).

    thanks again.
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    19 Mar 2010
    Link to this post
    Hello Scott Rozman,

    Could you please try adding the following style rule to your CSS rules:
    .RadMenu {
    position:static !important;
    }

    Greetings,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  5. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    19 Mar 2010
    Link to this post
    Thanks a lot for the quick fix!
Register for webinar
5 posts, 1 answered