+1-888-365-2779
Try Now
More in this section

Forums / Deployment / Deploying using Publish or Web Deployment Project

Deploying using Publish or Web Deployment Project

2 posts, 0 answered
  1. higgsy
    higgsy avatar
    336 posts
    Registered:
    05 Aug 2010
    10 Feb 2011
    Link to this post
    Hi,

    I have a solution that has the main web app, plus two class libraries. The class libraries have references to the main sitefinity assemblies (those that it requires).

    When I try to publish the solution, or create and build a web deployment project, the build process exits with errors. The errors are always from one of the class libraries, stating:

    The type or namespace name 'Sitefinity' does not exist in the namespace 'Telerik' (are you missing an assembly reference?

    Everything works fine if I build under the Debug setting, but if I build under the Release setting it errors everytime.

    Any idea why?

    Thanks
    higgsy
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    16 Feb 2011
    Link to this post
    Hi higgsy,

    Thank you for using our services.

    We are unsure why this would be caused on your projects. Can you please check from where your projects are pulling references? Can you please try puling the reference assemblies from the Libraries folder in the installation directory of Sitefinity 4.0? We are building the SDK samples in release mode and we have not had such problems.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
2 posts, 0 answered